Commit 97a7ffa6 authored by André Kerkhoff's avatar André Kerkhoff
Browse files

Fix error message in HolidaylistPlugin patch

parent b3803894
...@@ -5,5 +5,5 @@ DEPENDENCIES ...@@ -5,5 +5,5 @@ DEPENDENCIES
GRAPH GRAPH
apache2 (5.2.1) apache2 (5.2.1)
foswiki (2.6.0) foswiki (2.6.1)
apache2 (< 6.0) apache2 (< 6.0)
...@@ -1053,7 +1053,7 @@ sub _renderHolidayList() { ...@@ -1053,7 +1053,7 @@ sub _renderHolidayList() {
my $bgcolor; my $bgcolor;
$bgcolor = $options{weekendbgcolor} unless $dow < 6; $bgcolor = $options{weekendbgcolor} unless $dow < 6;
my $pubholidaybgcolor = ( $$iconTableRef{'!!__@ALL__!!'}[$i] . ' ' . $options{pubholidayicon} ); my $pubholidaybgcolor = ( $$iconTableRef{'!!__@ALL__!!'}[$i] || '' ) . ' ' . $options{pubholidayicon};
$pubholidaybgcolor =~ s/.*\bcolor\(([^\)]+)\).*/$1/; $pubholidaybgcolor =~ s/.*\bcolor\(([^\)]+)\).*/$1/;
$bgcolor = $pubholidaybgcolor $bgcolor = $pubholidaybgcolor
if ( $options{enablepubholidays} if ( $options{enablepubholidays}
......
...@@ -3,7 +3,7 @@ maintainer 'HPC' ...@@ -3,7 +3,7 @@ maintainer 'HPC'
maintainer_email 'hpc@gsi.de' maintainer_email 'hpc@gsi.de'
license 'All rights reserved' license 'All rights reserved'
description 'Installs/Configures Foswiki' description 'Installs/Configures Foswiki'
version '2.6.0' version '2.6.1'
depends 'apache2', '< 6.0' depends 'apache2', '< 6.0'
supports 'debian' supports 'debian'
supports 'ubuntu' supports 'ubuntu'
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment