diff --git a/lustre/demos/Makefile b/lustre/demos/Makefile
index 85e6e5bc3c828e1077072a56f2e2035a425fd1ef..18c2cd954a51894c7c17b2b867b6259a651076ed 100644
--- a/lustre/demos/Makefile
+++ b/lustre/demos/Makefile
@@ -1,3 +1,7 @@
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 all: perms
 
 perms:
diff --git a/lustre/demos/baseclean.sh b/lustre/demos/baseclean.sh
index 342599f754ff45349a4f3b580f3f2f664affc045..033c8d8e73380826bac02c9bf186daa2c2c76720 100755
--- a/lustre/demos/baseclean.sh
+++ b/lustre/demos/baseclean.sh
@@ -1,5 +1,10 @@
 #!/bin/sh
 # Script to remove the loopback device and temp file created in newtest.sh
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/basesetup.sh b/lustre/demos/basesetup.sh
index 86bdd9783beaa300fc8bf2c8d63d1969b766ad2d..ba7db5b0891760797fe0ea8ffcec885405a62a9f 100755
--- a/lustre/demos/basesetup.sh
+++ b/lustre/demos/basesetup.sh
@@ -1,5 +1,10 @@
 #! /bin/sh
 # Get the locations for the files from a single place to avoid confusion
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 OBDDIR="`dirname $0`/.."
 
 # source config info
diff --git a/lustre/demos/config.sh b/lustre/demos/config.sh
index 96d074dc111521a981fab551f1dad180ff34f7dd..2ff55e302a57a6f6f0b05b9dc4a860fe838eded2 100644
--- a/lustre/demos/config.sh
+++ b/lustre/demos/config.sh
@@ -2,6 +2,11 @@
 # File which holds configuation parameters in a single place to avoid any
 # mismatch between scripts (especially the cleanup scripts, which are
 # destructive).
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 #set -vx
 
 # Major number for OBD devices
diff --git a/lustre/demos/obdfsclean.sh b/lustre/demos/obdfsclean.sh
index a001c5ecbdc57ca1fa20df38e89b9d560e4dd2ab..42fd2b265263db86414c4af38002b1a32b75cc68 100755
--- a/lustre/demos/obdfsclean.sh
+++ b/lustre/demos/obdfsclean.sh
@@ -1,5 +1,11 @@
 #!/bin/sh
 # Utility script for cleaning up a simple OBDFS mounted filesystem
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/obdfssetup.sh b/lustre/demos/obdfssetup.sh
index 46dcc2b219821c23004e0ede2f394367a0c9c2c4..c88e92ee9ea389195282b86be99ebcd92c225f7c 100755
--- a/lustre/demos/obdfssetup.sh
+++ b/lustre/demos/obdfssetup.sh
@@ -1,5 +1,11 @@
 #! /bin/bash
 # Utility script for configuring a simple OBDFS mount
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 .  $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/obdtest.sh b/lustre/demos/obdtest.sh
index c30a0feadbde169366a84b0b797c8f35d6e1d87d..e1235f24693a8f89b5743c25face23f12bd6eca2 100755
--- a/lustre/demos/obdtest.sh
+++ b/lustre/demos/obdtest.sh
@@ -2,6 +2,12 @@
 # Utility script to create an OBD snapshot.  If an existing filesystem is
 # not already mounted on /mnt/obd, we call the basic OBD setup script to
 # create and mount a filesystem for us.
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snap3clean.sh b/lustre/demos/snap3clean.sh
index 63a04a203deb810569f23fe850cb6cc3ac802a05..0897ea9e09d50673631f9b22c3fe23062fc3e7d4 100755
--- a/lustre/demos/snap3clean.sh
+++ b/lustre/demos/snap3clean.sh
@@ -1,5 +1,11 @@
 #!/bin/sh
 # Utility script for cleaning up a third snapshot created by setup3.sh
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snap3set.sh b/lustre/demos/snap3set.sh
index c314f30b4179b02d9175f97eac6cd3a6d873ca25..197c5da3ad0fdcdc578227f9993915229bd9fde9 100755
--- a/lustre/demos/snap3set.sh
+++ b/lustre/demos/snap3set.sh
@@ -1,5 +1,11 @@
 #!/bin/sh
 # Utility script for creating a third snapshot.
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snapclean.sh b/lustre/demos/snapclean.sh
index 04df14fa0c76112e94c186409873cfce81324dd6..4d2d4567bf5fe0f42b3f17114ce5e72f9dcf2a39 100755
--- a/lustre/demos/snapclean.sh
+++ b/lustre/demos/snapclean.sh
@@ -1,5 +1,11 @@
 #! /bin/bash
 # Utility script for cleaning up snapshots and removing modules.
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snapdel.sh b/lustre/demos/snapdel.sh
index 7fc872de9e6a82187bede98f5d954c463c2d3a86..87607f56d1a5d19317ba369c24e4a0c5179a1f6e 100755
--- a/lustre/demos/snapdel.sh
+++ b/lustre/demos/snapdel.sh
@@ -1,6 +1,12 @@
 #!/bin/sh
 # Utility script to test deleting a snapshot that has been previously
 # created as the setup.sh script does.
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snaprest.sh b/lustre/demos/snaprest.sh
index bc778e3e7c64a3c9d5d215ecfe397d7904c4903b..9a5dd070aa05a54169fad39cde1b438fa080434a 100755
--- a/lustre/demos/snaprest.sh
+++ b/lustre/demos/snaprest.sh
@@ -1,6 +1,12 @@
 #!/bin/sh
 # Utility script to test restoring a previous snapshot.  This will destroy
 # the "current" snapshot and restore the old one in its place.
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snaprestclean.sh b/lustre/demos/snaprestclean.sh
index 52c6ceee4afe877ccc25ba687967ed85cb801184..a3c4319c8fe40a9abfbe5ebf3a9c0a2638475594 100755
--- a/lustre/demos/snaprestclean.sh
+++ b/lustre/demos/snaprestclean.sh
@@ -1,5 +1,11 @@
 #! /bin/bash
 # Utility script for cleaning up a simple OBDFS mounted filesystem
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snapsetup.sh b/lustre/demos/snapsetup.sh
index b8b5eaae9255992fe066fd1e7f3cb7347a2dd47e..ff95718b04a42c122aea3de1e5d6d83dc9bdf900 100755
--- a/lustre/demos/snapsetup.sh
+++ b/lustre/demos/snapsetup.sh
@@ -2,6 +2,12 @@
 # Utility script to create an OBD snapshot.  If an existing filesystem is
 # not already mounted on /mnt/obd, we call the basic OBD setup script to
 # create and mount a filesystem for us.
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/demos/snaptest.sh b/lustre/demos/snaptest.sh
index bd0a4ea1c9ae4267f2159381aedeea44bdc1c707..675a52962f2049fc0cd8352c364b349fa6b82105 100755
--- a/lustre/demos/snaptest.sh
+++ b/lustre/demos/snaptest.sh
@@ -1,6 +1,12 @@
 #!/bin/sh
 # Utility script to perform minor modifications to the read-write mounted
 # snapshot in order to demonstrate the changes w.r.t. the read-only snapshot
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/include/linux/Makefile b/lustre/include/linux/Makefile
index 1f77ee4f87c18b6898e75715b7bc5894f26ea9ed..c263b40602201d2d7c8c3057e7b4b6c0b845b8c7 100644
--- a/lustre/include/linux/Makefile
+++ b/lustre/include/linux/Makefile
@@ -1,3 +1,7 @@
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 
 all .DEFAULT: 
 	$(MAKE) -C ../..  $@
diff --git a/lustre/include/linux/inofs.h b/lustre/include/linux/inofs.h
index a5a205d7f24e4afa309d95097827bd9838d5687a..1ed3220d8466eb96e6e6c6bb203440d66a4d1290 100644
--- a/lustre/include/linux/inofs.h
+++ b/lustre/include/linux/inofs.h
@@ -1,7 +1,7 @@
 /* object based disk file system
  * 
- * This software is licensed under the GPL.  See the file COPYING in the
- * top directory of this distribution for details.
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
  * 
  * Copyright (C), 1999, Stelias Computing Inc
  *
diff --git a/lustre/include/linux/obd.h b/lustre/include/linux/obd.h
index a73c64f3f78cebb40dad1694cebc38c545970e84..674a19a372a5bb882ce9ca5bce854b51601bd419 100644
--- a/lustre/include/linux/obd.h
+++ b/lustre/include/linux/obd.h
@@ -1,6 +1,11 @@
 #ifndef __OBD_H
 #define __OBD_H
-
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 struct obd_conn_info {
         unsigned int conn_id;     /* handle */
diff --git a/lustre/include/linux/obd_class.h b/lustre/include/linux/obd_class.h
index 50e9d82b863ec46cee089ee2bfc890a923de1389..c29b278889df4f383da3903a18e97e7cca89f501 100644
--- a/lustre/include/linux/obd_class.h
+++ b/lustre/include/linux/obd_class.h
@@ -1,5 +1,11 @@
 #ifndef __LINUX_CLASS_OBD_H
 #define __LINUX_CLASS_OBD_H
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 #include <linux/fs.h>
 #include <linux/time.h>
diff --git a/lustre/include/linux/obd_ext2.h b/lustre/include/linux/obd_ext2.h
index 571958cb91cc098f3128e5abd8643afd037fcc81..6ab1b488b25dccbb9e9f3c8a23748e6618dd8547 100644
--- a/lustre/include/linux/obd_ext2.h
+++ b/lustre/include/linux/obd_ext2.h
@@ -1,5 +1,11 @@
 #ifndef _OBD_EXT2
 #define _OBD_EXT2
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 #define OBD_EXT2_RUNIT           _IOWR('f', 61, long)
 
diff --git a/lustre/include/linux/obd_raid1.h b/lustre/include/linux/obd_raid1.h
index e28a708ace438c9449f750b2607b993eec98e644..b99161e4f6e3f61767ae24f2da2aacf86d542dbb 100644
--- a/lustre/include/linux/obd_raid1.h
+++ b/lustre/include/linux/obd_raid1.h
@@ -1,5 +1,11 @@
 #ifndef _OBD_RAID1
 #define _OBD_RAID1
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 #include <linux/obd_class.h>
 
diff --git a/lustre/include/linux/obd_rpc.h b/lustre/include/linux/obd_rpc.h
index 64372c1524dd03b56e00d5967b2114a5c7291ce0..af0f878c5d5727fa65213495eb449b13c049c642 100644
--- a/lustre/include/linux/obd_rpc.h
+++ b/lustre/include/linux/obd_rpc.h
@@ -1,5 +1,11 @@
 #ifndef __OBD_RPC_H
 #define __OBD_RPC_H
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 #include <linux/sunrpc/svc.h>
 #define OBD_TGT_VERSION  001
diff --git a/lustre/include/linux/obd_snap.h b/lustre/include/linux/obd_snap.h
index 74890c560d7bd66aadfd3b3040b6157d36303d7a..4b40801597f34757ad1db441a1d97f2f9731faf0 100644
--- a/lustre/include/linux/obd_snap.h
+++ b/lustre/include/linux/obd_snap.h
@@ -1,5 +1,11 @@
 #ifndef _OBD_SNAP
 #define _OBD_SNAP
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 #define OBD_SNAP_MAGIC 0xfffffff3   /* an unlikely block number */
 
diff --git a/lustre/include/linux/obd_snap_support.h b/lustre/include/linux/obd_snap_support.h
index ff8fc9a94c706584dc0339ad9971df54cc4637c0..e7dd0125631920e5d236596a373ce89a7b29b74d 100644
--- a/lustre/include/linux/obd_snap_support.h
+++ b/lustre/include/linux/obd_snap_support.h
@@ -1,5 +1,11 @@
 #ifndef __OBD_SNAP_SUPP_H
 #define __OBD_SNAP_SUPP_H
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 /* What we use to point to IDs in the obdmd data for snapshots.  If we use
  * obd_id (8 bytes) instead of ino_t (4 bytes), we halve the number of
diff --git a/lustre/include/linux/obd_support.h b/lustre/include/linux/obd_support.h
index 841f4bec9fe6df8294255c20c31a834c2adfbb18..b8202c33d5e2284b50a184ecdcfaf3f1f588f296 100644
--- a/lustre/include/linux/obd_support.h
+++ b/lustre/include/linux/obd_support.h
@@ -1,5 +1,12 @@
 #ifndef _OBD_SUPPORT
 #define _OBD_SUPPORT
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
+
 #include <linux/autoconf.h>
 #include <linux/slab.h>
 #include <linux/vmalloc.h>
diff --git a/lustre/include/linux/obd_trace.h b/lustre/include/linux/obd_trace.h
index 27b05c5d8015890896118c9b93ad788c334a4a54..00e16bbfa13a0c944f354c1241947dce3ec0b58c 100644
--- a/lustre/include/linux/obd_trace.h
+++ b/lustre/include/linux/obd_trace.h
@@ -1,4 +1,7 @@
 /*
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * obdtrace (header file) - is useful for tracing and performance
  * debug of the Lustre obd protocol stack. obdtrace is a transparent
  * logical obd driver that prints commands their in- and outbound
diff --git a/lustre/include/linux/obdfs.h b/lustre/include/linux/obdfs.h
index 5a0951e477bb7ab71836ef7727a5c0e8a933e7be..ed8198c32b04389eb41e42eed156ea30092e6c2d 100644
--- a/lustre/include/linux/obdfs.h
+++ b/lustre/include/linux/obdfs.h
@@ -1,7 +1,7 @@
 /* object based disk file system
  * 
- * This software is licensed under the GPL.  See the file COPYING in the
- * top directory of this distribution for details.
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
  * 
  * Copyright (C), 1999, Stelias Computing Inc
  *
diff --git a/lustre/include/linux/obdo.h b/lustre/include/linux/obdo.h
index 41df0138615ebd8ce884cc4828451509bfa6a2da..6e257e9e76f9482d5d333d8c67e80ccce386804c 100644
--- a/lustre/include/linux/obdo.h
+++ b/lustre/include/linux/obdo.h
@@ -1,5 +1,11 @@
 #ifndef OBD_H
 #define OBD_H
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 
 struct obdfs_inode_info {
         int              oi_flags;
diff --git a/lustre/obdclass/Makefile b/lustre/obdclass/Makefile
index 6f211bb37902af876a15bd1b464d92c2f36a0ed1..896bce2724367aeedb39e4f34dcb3e77e201636c 100644
--- a/lustre/obdclass/Makefile
+++ b/lustre/obdclass/Makefile
@@ -1,3 +1,7 @@
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 
 MODULE = obdclass.o
 bin_PROGRAMS = obdcontrol
diff --git a/lustre/obdclass/genops.c b/lustre/obdclass/genops.c
index b1c88e6d058db7a6bf7f9634e33e8ea7b690737f..a261dd866337c674b6b824a44210b29950b13223 100644
--- a/lustre/obdclass/genops.c
+++ b/lustre/obdclass/genops.c
@@ -1,5 +1,9 @@
 /*
  *  linux/fs/ext2_obd/sim_obd.c
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
  *
  * These are the only exported functions; they provide the simulated object-
  * oriented disk.
diff --git a/lustre/obdclass/proc_lustre.c b/lustre/obdclass/proc_lustre.c
index fcd71589012f0a890b1d63ba1fd84e2f4db919ee..f83e7a637643386dbb9d9a07172c57d88860d263 100644
--- a/lustre/obdclass/proc_lustre.c
+++ b/lustre/obdclass/proc_lustre.c
@@ -1,4 +1,9 @@
 /* proc_lustre.c manages /proc/lustre/obd. 
+ *
+ * Copyright (c) 2001 Rumi Zahir <rumi.zahir@intel.com>
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
  *
  * OBD devices materialize in /proc as a directory:
  *              /proc/lustre/obd/<number>
@@ -29,8 +34,6 @@
  *     proc_lustre_remove_obd_entry() removes a
  *     /proc/lustre/obd/<obdid>/ entry by name. This is the only
  *     function that is exported to other modules. 
- *
- * Copyright (c) 2001 Rumi Zahir <rumi.zahir@intel.com>
  */
 
 #include <linux/config.h>
diff --git a/lustre/obdclass/sysctl.c b/lustre/obdclass/sysctl.c
index 3944b03e1ebd9bea1339faae3c031488756b0cdf..e080dadde7d708fd5b268068b1de608964edc567 100644
--- a/lustre/obdclass/sysctl.c
+++ b/lustre/obdclass/sysctl.c
@@ -1,3 +1,10 @@
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
+
 #include <linux/module.h>
 #include <linux/autoconf.h>
 #include <linux/sysctl.h>
diff --git a/lustre/obdfs/Makefile b/lustre/obdfs/Makefile
index d07e8d79dd5658da13d86e227f7531a44aa41360..ac24ec733e6044b6bc36e0472255f675415bafc1 100644
--- a/lustre/obdfs/Makefile
+++ b/lustre/obdfs/Makefile
@@ -1,3 +1,7 @@
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 MODULE = obdfs.o
 CFILES=  flushd.c rw.c file.c dir.c sysctl.c super.c namei.c symlink.c
 
diff --git a/lustre/obdfs/dir.c b/lustre/obdfs/dir.c
index 59e6fb0b8584c765f0e514f0b94ab136d14cc2eb..1462f3016840612d7736a5c27506343a2114f385 100644
--- a/lustre/obdfs/dir.c
+++ b/lustre/obdfs/dir.c
@@ -1,6 +1,9 @@
 /*
  *  linux/fs/ext2/dir.c
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * Copyright (C) 1992, 1993, 1994, 1995
  * Remy Card (card@masi.ibp.fr)
  * Laboratoire MASI - Institut Blaise Pascal
diff --git a/lustre/obdfs/file.c b/lustre/obdfs/file.c
index 7968f10d9c675e73f66fec2b950a866fc02ece86..ff07ce3770cbe6849790fdcbb81c5228eeace02b 100644
--- a/lustre/obdfs/file.c
+++ b/lustre/obdfs/file.c
@@ -1,6 +1,9 @@
 /*
  *  linux/fs/ext2/file.c
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * Copyright (C) 1992, 1993, 1994, 1995
  * Remy Card (card@masi.ibp.fr)
  * Laboratoire MASI - Institut Blaise Pascal
diff --git a/lustre/obdfs/flushd.c b/lustre/obdfs/flushd.c
index a1d0cb08ca4bb2c26ea1ba282ec75ea5c841b35c..439eff3519fbf0768891598ffe66d82df2bde226 100644
--- a/lustre/obdfs/flushd.c
+++ b/lustre/obdfs/flushd.c
@@ -2,6 +2,9 @@
  * OBDFS Super operations - also used for Lustre file system
  *
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  *  Copyright (C) 1991, 1992  Linus Torvalds
  * Copryright (C) 1999 Stelias Computing Inc. <braam@stelias.com>
  * Copryright (C) 1999 Seagate Technology Inc.
diff --git a/lustre/obdfs/namei.c b/lustre/obdfs/namei.c
index 66bba9e0f801a90f2d490897ac5aaf166ebb4252..e8993038c6044fb85d488e2258cecd4ac298e650 100644
--- a/lustre/obdfs/namei.c
+++ b/lustre/obdfs/namei.c
@@ -1,6 +1,9 @@
 /*
  *  linux/fs/obdfs/namei.c
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * Copyright (C) 1992, 1993, 1994, 1995
  * Remy Card (card@masi.ibp.fr)
  * Laboratoire MASI - Institut Blaise Pascal
diff --git a/lustre/obdfs/rw.c b/lustre/obdfs/rw.c
index 90894b39f114651bab6ef4a9bee1d90d39dba129..316be95c425f2be8f98a81cac1c64cfd382a6074 100644
--- a/lustre/obdfs/rw.c
+++ b/lustre/obdfs/rw.c
@@ -1,6 +1,9 @@
 /*
  * OBDFS Super operations
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * Copyright (C) 1996, 1997, Olaf Kirch <okir@monad.swb.de>
  * Copryright (C) 1999 Stelias Computing Inc, 
  *                (author Peter J. Braam <braam@stelias.com>)
diff --git a/lustre/obdfs/super.c b/lustre/obdfs/super.c
index 35458276da8488062216b0c49465dd34aacc54a3..1fb04443a226dcddd93d0c8cc7315f27b360a8ce 100644
--- a/lustre/obdfs/super.c
+++ b/lustre/obdfs/super.c
@@ -1,6 +1,9 @@
 /*
  * OBDFS Super operations
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * Copryright (C) 1996 Peter J. Braam <braam@stelias.com>
  * Copryright (C) 1999 Stelias Computing Inc. <braam@stelias.com>
  * Copryright (C) 1999 Seagate Technology Inc.
diff --git a/lustre/obdfs/symlink.c b/lustre/obdfs/symlink.c
index 396176cd26e1851a1cb54b1f8c7955155a39440b..a42c0ab8cfce074828f12e6f571b84ac8491ecba 100644
--- a/lustre/obdfs/symlink.c
+++ b/lustre/obdfs/symlink.c
@@ -1,6 +1,9 @@
 /*
  *  linux/fs/ext2/symlink.c
  *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ *
  * Copyright (C) 1992, 1993, 1994, 1995
  * Remy Card (card@masi.ibp.fr)
  * Laboratoire MASI - Institut Blaise Pascal
diff --git a/lustre/obdfs/sysctl.c b/lustre/obdfs/sysctl.c
index be63d570b9432576cf2ed0468a562eac7b774f66..c03b0289999f92a04c9a6b8274152ac10935e87b 100644
--- a/lustre/obdfs/sysctl.c
+++ b/lustre/obdfs/sysctl.c
@@ -1,3 +1,9 @@
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
 #include <linux/sched.h>
 #include <linux/mm.h>
 #include <linux/sysctl.h>
diff --git a/lustre/scripts/license-status b/lustre/scripts/license-status
new file mode 100755
index 0000000000000000000000000000000000000000..5407b9140abe77214b8fbb754aa43dd82cfdb45b
--- /dev/null
+++ b/lustre/scripts/license-status
@@ -0,0 +1,26 @@
+#! /bin/sh
+# license-status - Display the status of files in the current directory
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+#
+# Gordon Matzigkeit <gord@fig.org>, 2001-09-27
+
+for f in `find . -type f | sort`; do
+ case "$f" in
+ *~ | *.orig | *.gz | */config.* | *.o | \
+ */CVS/* | */.cvsignore | */.depfiles/* | \
+ */COPYING | */ChangeLog)
+  continue
+  ;;
+ esac
+
+ if head -20 "$f" | egrep -e 'GNU' > /dev/null; then
+  echo "gpled $f"
+ elif head -20 "$f" | egrep -e '\([Cc]\)' > /dev/null; then
+  echo "copyrighted $f"
+ else
+  echo "bare $f"
+ fi
+done | sort
diff --git a/lustre/scripts/maketags.sh b/lustre/scripts/maketags.sh
index 7f3a7933d9650e1de3cc4f9fbe3351309b915f69..9bd9f8734625d327e615bd805f5188ea5c38f63e 100755
--- a/lustre/scripts/maketags.sh
+++ b/lustre/scripts/maketags.sh
@@ -1,4 +1,8 @@
 #!/bin/sh
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 set -vx
 rm -f TAGS ; find . -name '*.h' -or -name '*.c' | xargs etags
 rm -f ctags; find . -name '*.h' -or -name '*.c' | xargs ctags
diff --git a/lustre/scripts/mass_install b/lustre/scripts/mass_install
index d5275f1ad01b41db981d48f22155a3465084310d..79921f0f6483f6c0b35f34ee2377082462c18670 100755
--- a/lustre/scripts/mass_install
+++ b/lustre/scripts/mass_install
@@ -1,6 +1,10 @@
 #! /bin/sh
 # mass_install - Install zero or more files in a directory
 # Gordon Matzigkeit <gord@fig.org>, 2001-09-26
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 
 # Usage: mass_install DIR [FILES...] [OPTS...]
 FILES=
diff --git a/lustre/scripts/mkobddevs b/lustre/scripts/mkobddevs
index 6dd8750405443787206cb6cc0788502be00e4555..a35631d828fc28622b2cbac5e7b0fb4977cfa0a9 100755
--- a/lustre/scripts/mkobddevs
+++ b/lustre/scripts/mkobddevs
@@ -1,4 +1,9 @@
 #!/bin/sh -x
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 mknod -m 0600 /dev/obd0 c 186 0
 mknod -m 0600 /dev/obd1 c 186 1
 mknod -m 0600 /dev/obd2 c 186 2
diff --git a/lustre/scripts/obdtrace_demo.scr b/lustre/scripts/obdtrace_demo.scr
index 2bfc6d5e0174d1d1a0585bd2b2fcad9d10fb9612..0601235bcd746c0b840a22ce4a1696ba522bd93f 100644
--- a/lustre/scripts/obdtrace_demo.scr
+++ b/lustre/scripts/obdtrace_demo.scr
@@ -1,3 +1,7 @@
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 # Print OS version
 shell uname -r
 # Insert Lustre kernel modules
diff --git a/lustre/scripts/patch-if-change b/lustre/scripts/patch-if-change
index 4dd40799b228ab4356f9af4e87a3736cca675fe6..9af32d41f5b51688fc81426254f5c7e6e76c2ab2 100755
--- a/lustre/scripts/patch-if-change
+++ b/lustre/scripts/patch-if-change
@@ -2,6 +2,10 @@
 # patch-if-change - Copy FILES to the current directory, apply PATCH,
 # and restore timestamps on files that weren't changed.
 # Gordon Matzigkeit <gord@fig.org>, 2001-09-25
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 
 # Usage: patch-if-change [PATCHFLAGS]... PATCH FILES...
 PATCHFLAGS=
diff --git a/lustre/tests/fs.sh b/lustre/tests/fs.sh
index e94c949fa16076bee7236d4116ed343a2f3a29b9..23a4a67d073254a5342feb8fc0ec3ea68ff44187 100644
--- a/lustre/tests/fs.sh
+++ b/lustre/tests/fs.sh
@@ -1,4 +1,8 @@
 #! /bin/bash
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
 
 insmod loop
 dd if=/dev/zero of=/tmp/fs bs=1024 count=10000
diff --git a/lustre/tests/snaprun.sh b/lustre/tests/snaprun.sh
index 4eb09c66b563f7ef54079d7188858ac1e3dd6582..ea77cfb704057edb7b43caf86d5bf8a37939c7d4 100755
--- a/lustre/tests/snaprun.sh
+++ b/lustre/tests/snaprun.sh
@@ -1,6 +1,12 @@
 #!/bin/sh
 # Utility script to test several features of a snapshot filesystem
 # Assumes that snapshot has already been configured
+#
+# Copyright (C) 2001  Cluster File Systems, Inc.
+#
+# This code is issued under the GNU General Public License.
+# See the file COPYING in this distribution
+
 OBDDIR="`dirname $0`/.."
 . $OBDDIR/demos/config.sh
 
diff --git a/lustre/tests/test.c b/lustre/tests/test.c
index c79a640c80db620ca893c2d0b82ea828ebdae03e..b941d78dc3afd908031fe08eb6343257b84c3fb0 100755
--- a/lustre/tests/test.c
+++ b/lustre/tests/test.c
@@ -1,3 +1,10 @@
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
+
 #include <stdio.h>
 #include <stdlib.h>
 #include <fcntl.h>
diff --git a/lustre/tests/test2.c b/lustre/tests/test2.c
index 4d486af68366a01fe0e0fd711ac61b023c0080f4..fbbe6bb3614bf86a538d224b94a424d4ef505e83 100755
--- a/lustre/tests/test2.c
+++ b/lustre/tests/test2.c
@@ -1,3 +1,10 @@
+/*
+ * Copyright (C) 2001  Cluster File Systems, Inc.
+ *
+ * This code is issued under the GNU General Public License.
+ * See the file COPYING in this distribution
+ */
+
 #include <stdio.h>
 #include <stdlib.h>
 #include <fcntl.h>