diff --git a/lustre/doc/Makefile.am b/lustre/doc/Makefile.am
index fd5a857277970e9d7f4c401fb4cc96245fc11dbe..a78044806dec66c420aba5146802a7efc4ac1753 100644
--- a/lustre/doc/Makefile.am
+++ b/lustre/doc/Makefile.am
@@ -87,13 +87,15 @@ chbar: lustre-chbar.pdf
 %-chbar.tex: chbar.sh postbar doc.old/%-full.tex %-full.tex
 	$(SHELL) $(srcdir)/chbar.sh doc.old/$*-full.tex $*-full.tex | $(srcdir)/postbar > $@
 
-%-full.tex: %.tex
-	$(TEXEXPAND) -texinputs=. -texinputs=$(srcdir) -output=$@ $<
-
+# This rule needs to come before the next %-full.tex rule.
 doc.old/lustre.tex: doc.old/lustre-HOWTO.lyx
 doc.old/%-full.tex: doc.old/%.tex
 	cd doc.old && $(TEXEXPAND) -texinputs=. -output=$*-full.tex $*.tex
 
+# This rule needs to come after the more specific doc.old rule.
+%-full.tex: %.tex
+	$(TEXEXPAND) -texinputs=. -texinputs=$(srcdir) -output=$@ $<
+
 # Check out the old directory if it doesn't exist.
 doc.old/lustre.lin doc.old/lustre-HOWTO.lin:
 	@if test "X$(OLD)" = X; then \