diff --git a/lustre/include/obd.h b/lustre/include/obd.h
index 14f88ca8c948e44887e56f06aff2a658b54b836c..67d10f62b810c42336c5846050d165d0772ce6e8 100644
--- a/lustre/include/obd.h
+++ b/lustre/include/obd.h
@@ -1418,11 +1418,11 @@ static inline void obd_transno_commit_cb(struct obd_device *obd, __u64 transno,
                                          int error)
 {
         if (error) {
-                CERROR("%s: transno "LPD64" commit error: %d\n",
+                CERROR("%s: transno "LPU64" commit error: %d\n",
                        obd->obd_name, transno, error);
                 return;
         }
-        CDEBUG(D_HA, "%s: transno "LPD64" committed\n",
+        CDEBUG(D_HA, "%s: transno "LPU64" committed\n",
                obd->obd_name, transno);
         if (transno > obd->obd_last_committed) {
                 obd->obd_last_committed = transno;
diff --git a/lustre/lov/lov_qos.c b/lustre/lov/lov_qos.c
index f3813a32310a32976829d832a359d3f840481db2..aa3f288d623dac222593ccde46cc98c505ecc583 100644
--- a/lustre/lov/lov_qos.c
+++ b/lustre/lov/lov_qos.c
@@ -974,7 +974,8 @@ int qos_prep_create(struct obd_export *exp, struct lov_request_set *set)
 out_err:
         if (newea && rc)
                 obd_free_memmd(exp, &set->set_oi->oi_md);
-        free_idx_array(idx_arr, idx_cnt);
+        if (idx_arr)
+                free_idx_array(idx_arr, idx_cnt);
         EXIT;
         return rc;
 }
diff --git a/lustre/scripts/Makefile.am b/lustre/scripts/Makefile.am
index f0a44a33e4ca7ad55b8da3670a6064b5e35a6ab4..031a9889b580e40cfb4ee046120a424fe901ac7c 100644
--- a/lustre/scripts/Makefile.am
+++ b/lustre/scripts/Makefile.am
@@ -15,7 +15,7 @@ EXTRA_DIST = license-status maketags.sh version_tag.pl.in lc_common \
 	     $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
 	     $(bin_SCRIPTS)
 
-scriptlibdir = $(libdir)/@PACKAGE@
+scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_DATA = lc_common
 
 CLEANFILES = $(genscripts)