From 0ce9212ee77a8ac965c6f1920c3d3614423d5a2f Mon Sep 17 00:00:00 2001
From: bwzhou <bwzhou>
Date: Sun, 18 May 2008 18:24:55 +0000
Subject: [PATCH] Branch b1_6 b=13285 r=green, bobijam (libexec) r=johann, deen
 (gcc)

1. Use the common libexec convention;
2. Quiet remaining gcc warnings.
---
 lustre/include/obd.h       | 4 ++--
 lustre/lov/lov_qos.c       | 3 ++-
 lustre/scripts/Makefile.am | 2 +-
 3 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/lustre/include/obd.h b/lustre/include/obd.h
index d6de0c92c4..94593cb04d 100644
--- a/lustre/include/obd.h
+++ b/lustre/include/obd.h
@@ -1113,11 +1113,11 @@ static inline void obd_transno_commit_cb(struct obd_device *obd, __u64 transno,
                                          int error)
 {
         if (error) {
-                CERROR("%s: transno "LPD64" commit error: %d\n",
+                CERROR("%s: transno "LPU64" commit error: %d\n",
                        obd->obd_name, transno, error);
                 return;
         }
-        CDEBUG(D_HA, "%s: transno "LPD64" committed\n",
+        CDEBUG(D_HA, "%s: transno "LPU64" committed\n",
                obd->obd_name, transno);
         if (transno > obd->obd_last_committed) {
                 obd->obd_last_committed = transno;
diff --git a/lustre/lov/lov_qos.c b/lustre/lov/lov_qos.c
index cf61023e0a..fe92246644 100644
--- a/lustre/lov/lov_qos.c
+++ b/lustre/lov/lov_qos.c
@@ -944,7 +944,8 @@ int qos_prep_create(struct obd_export *exp, struct lov_request_set *set)
 out_err:
         if (newea && rc)
                 obd_free_memmd(exp, &set->set_oi->oi_md);
-        free_idx_array(idx_arr, idx_cnt);
+        if (idx_arr)
+                free_idx_array(idx_arr, idx_cnt);
         EXIT;
         return rc;
 }
diff --git a/lustre/scripts/Makefile.am b/lustre/scripts/Makefile.am
index f0a44a33e4..031a9889b5 100644
--- a/lustre/scripts/Makefile.am
+++ b/lustre/scripts/Makefile.am
@@ -15,7 +15,7 @@ EXTRA_DIST = license-status maketags.sh version_tag.pl.in lc_common \
 	     $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
 	     $(bin_SCRIPTS)
 
-scriptlibdir = $(libdir)/@PACKAGE@
+scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_DATA = lc_common
 
 CLEANFILES = $(genscripts)
-- 
GitLab