diff --git a/lustre/scripts/lustre.spec.in b/lustre/scripts/lustre.spec.in
index 907a0b3778c393518fbf14b1985ef52834c972c6..2d0fa9f6d34ddec785797101b785e16cd5dcbf94 100644
--- a/lustre/scripts/lustre.spec.in
+++ b/lustre/scripts/lustre.spec.in
@@ -104,7 +104,7 @@ mkdir -p $RPM_BUILD_ROOT/var/lib/ldap/lustre
 %attr(-, root, root) /usr/sbin/wiretest
 %attr(-, root, root) /usr/sbin/lactive
 %attr(-, root, root) /usr/sbin/llanalyze
-%attr(-, root, root) /usr/sbin/lfs
+%attr(-, root, root) /usr/bin/lfs
 %attr(-, root, root) /usr/sbin/gmnalnid
 %attr(-, root, root) /usr/bin/lfind
 %attr(-, root, root) /usr/bin/lstripe
diff --git a/lustre/utils/Makefile.am b/lustre/utils/Makefile.am
index c0612fc9fb5bfa7b937e3e6c17ea5d01f4a238ba..6e3aad910d5e3728dd3c5193c3e327ec36480618 100644
--- a/lustre/utils/Makefile.am
+++ b/lustre/utils/Makefile.am
@@ -9,10 +9,11 @@ lctl_LDADD := $(LIBREADLINE) -lptlctl
 lfs_LDADD := $(LIBREADLINE) parser.o liblustreapi.a -lptlctl obd.o
 lload_LDADD := -lptlctl
 rootsbin_SCRIPTS = mount.lustre
-sbin_PROGRAMS = lctl obdio obdbarrier lload wirecheck wiretest lfs llmount
+sbin_PROGRAMS = lctl obdio obdbarrier lload wirecheck wiretest llmount
 sbin_SCRIPTS = lconf lmc llanalyze llstat.pl llobdstat.pl lactive load_ldap.sh lrun
 sbin_SCRIPTS += lwizard
 bin_SCRIPTS = lfind lstripe
+bin_PROGRAMS = lfs
 lib_LIBRARIES = liblustreapi.a
 liblustreapi_a_SOURCES = liblustreapi.c
 wirecheck_SOURCES = wirecheck.c