From 20f9ad832086a909f20c6e9d0511fb4dfcd26873 Mon Sep 17 00:00:00 2001
From: jacob <jacob>
Date: Sat, 17 Apr 2004 04:17:31 +0000
Subject: [PATCH] Fix --disable-modules build.

---
 lnet/Makefile.in                 | 14 +++++---------
 lnet/klnds/Makefile.in           |  4 ----
 lustre/Makefile.in               |  4 ----
 lustre/portals/Makefile.in       | 14 +++++---------
 lustre/portals/knals/Makefile.in |  4 ----
 5 files changed, 10 insertions(+), 30 deletions(-)

diff --git a/lnet/Makefile.in b/lnet/Makefile.in
index 455eaf41b3..71d0dc847d 100644
--- a/lnet/Makefile.in
+++ b/lnet/Makefile.in
@@ -1,13 +1,9 @@
-ifeq (@MODULES_TRUE@,)
-
 subdir-m += libcfs
-ifeq (@CRAY_PORTALS_FALSE@,)
-subdir-m += portals
-subdir-m += knals
-subdir-m += router
-subdir-m += tests
-endif # CRAY_PORTALS_FALSE
 
-endif # MODULES
+cray-subdirs += portals
+cray-subdirs += knals
+cray-subdirs += router
+cray-subdirs += tests
+@CRAY_PORTALS_FALSE@subdir-m += $(cray-subdirs)
 
 @INCLUDE_RULES@
diff --git a/lnet/klnds/Makefile.in b/lnet/klnds/Makefile.in
index 8b65144b63..12f0c247d1 100644
--- a/lnet/klnds/Makefile.in
+++ b/lnet/klnds/Makefile.in
@@ -1,11 +1,7 @@
-ifeq (@MODULES_TRUE@,)
-
 @BUILD_GMNAL_TRUE@subdir-m += gmnal
 @BUILD_IBNAL_TRUE@subdir-m += ibnal
 @BUILD_QSWNAL_TRUE@subdir-m += qswnal
 @BUILD_SCIMACNAL_TRUE@subdir-m += scimacnal
 subdir-m += socknal
 
-endif # MODULES_TRUE
-
 @INCLUDE_RULES@
diff --git a/lustre/Makefile.in b/lustre/Makefile.in
index 045da858cf..59849dbb1f 100644
--- a/lustre/Makefile.in
+++ b/lustre/Makefile.in
@@ -1,5 +1,3 @@
-ifeq (@MODULES_TRUE@,)
-
 subdir-m += portals
 
 @LDISKFS_TRUE@subdir-m  += ldiskfs
@@ -24,6 +22,4 @@ endif # PATCHLEVEL = 4
 @SNAPFS_TRUE@subdir-m += snapfs
 @SMFS_TRUE@subdir-m += smfs
 
-endif # MODULES_TRUE
-
 @INCLUDE_RULES@
diff --git a/lustre/portals/Makefile.in b/lustre/portals/Makefile.in
index 455eaf41b3..71d0dc847d 100644
--- a/lustre/portals/Makefile.in
+++ b/lustre/portals/Makefile.in
@@ -1,13 +1,9 @@
-ifeq (@MODULES_TRUE@,)
-
 subdir-m += libcfs
-ifeq (@CRAY_PORTALS_FALSE@,)
-subdir-m += portals
-subdir-m += knals
-subdir-m += router
-subdir-m += tests
-endif # CRAY_PORTALS_FALSE
 
-endif # MODULES
+cray-subdirs += portals
+cray-subdirs += knals
+cray-subdirs += router
+cray-subdirs += tests
+@CRAY_PORTALS_FALSE@subdir-m += $(cray-subdirs)
 
 @INCLUDE_RULES@
diff --git a/lustre/portals/knals/Makefile.in b/lustre/portals/knals/Makefile.in
index 8b65144b63..12f0c247d1 100644
--- a/lustre/portals/knals/Makefile.in
+++ b/lustre/portals/knals/Makefile.in
@@ -1,11 +1,7 @@
-ifeq (@MODULES_TRUE@,)
-
 @BUILD_GMNAL_TRUE@subdir-m += gmnal
 @BUILD_IBNAL_TRUE@subdir-m += ibnal
 @BUILD_QSWNAL_TRUE@subdir-m += qswnal
 @BUILD_SCIMACNAL_TRUE@subdir-m += scimacnal
 subdir-m += socknal
 
-endif # MODULES_TRUE
-
 @INCLUDE_RULES@
-- 
GitLab