Commit 21418464 authored by James Nunez's avatar James Nunez Committed by Oleg Drokin
Browse files

LU-11782 tests: add version check to conf-sanity 117

conf-sanity test 117 was added to check error returns from
read_param().  This test will fail when run with servers
with Lustre version less than 2.12.0 and, thus, should be
skipped for all Lustre servers earlier than 2.12.0.

Fixes: 6ca2425c

 ("LU-11198 utils: propagate errors for read_param")
Test-Parameters: trivial
Test-Parameters: serverversion=2.10.8 serverdistro=el7.6 env=ONLY=117 testlist=conf-sanity
Signed-off-by: default avatarJames Nunez <jnunez@whamcloud.com>
Change-Id: Ia0889584d9c1a6c09ea2a99fa11c7abfd1474de4
Reviewed-on: https://review.whamcloud.com/38851

Tested-by: default avatarjenkins <devops@whamcloud.com>
Tested-by: default avatarMaloo <maloo@whamcloud.com>
Reviewed-by: default avatarAndreas Dilger <adilger@whamcloud.com>
Reviewed-by: default avatarWei Liu <sarah@whamcloud.com>
parent ed064925
......@@ -8199,6 +8199,9 @@ test_116() {
run_test 116 "big size MDT support"
test_117() {
[[ "$OST1_VERSION" -lt $(version_code 2.12.0) ]] &&
skip "Need OST version at least 2.12.0"
setup
do_facet ost1 "$LCTL set_param ost.OSS.ost_io.nrs_policies=fifo"
do_facet ost1 "$LCTL get_param -n ost.OSS.ost_io.nrs_tbf_rule" &&
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment