diff --git a/lnet/lnet/Makefile.mk b/lnet/lnet/Makefile.mk
index 088902a0e054971f3a20325d9206425baedb1487..eaba11cc80b5c6d8200c2cb5a2d95405edf8d3c6 100644
--- a/lnet/lnet/Makefile.mk
+++ b/lnet/lnet/Makefile.mk
@@ -1,8 +1,3 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
-#
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
-
 include $(src)/../Kernelenv
 
 obj-y += portals.o
diff --git a/lnet/lnet/api-errno.c b/lnet/lnet/api-errno.c
index 9a4e5ac93485e56ddafe896910b6560c5de8a822..2f32cbf8ff5ca289450d9af5a8621b90df8778a8 100644
--- a/lnet/lnet/api-errno.c
+++ b/lnet/lnet/api-errno.c
@@ -5,6 +5,7 @@
  * Instantiate the string table of errors
  *
  *   This file is part of Lustre, http://www.sf.net/projects/lustre/
+ *   This file is not subject to copyright protection.
  */
 
 /* If you change these, you must update the number table in portals/errno.h */
diff --git a/lnet/lnet/autoMakefile.am b/lnet/lnet/autoMakefile.am
index 10cde66945c215ce00a5d7f7ac9267f9cf555efd..affce6ee564c8d2649c02674a9e96c669509889f 100644
--- a/lnet/lnet/autoMakefile.am
+++ b/lnet/lnet/autoMakefile.am
@@ -1,8 +1,3 @@
-# Copyright (C) 2002  Cluster File Systems, Inc.
-#
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
-
 my_sources =    api-errno.c api-ni.c api-wrap.c \
 		lib-init.c lib-me.c lib-msg.c lib-eq.c \
 		lib-md.c lib-move.c lib-ni.c lib-pid.c
diff --git a/lnet/lnet/lib-ni.c b/lnet/lnet/lib-ni.c
index 75086747e99f355285eddab993eb0c73697a7b98..cf273f8a1c0f5a0b04679fcbd950d44cf59d6456 100644
--- a/lnet/lnet/lib-ni.c
+++ b/lnet/lnet/lib-ni.c
@@ -1,25 +1,8 @@
 /* -*- mode: c; c-basic-offset: 8; indent-tabs-mode: nil; -*-
  * vim:expandtab:shiftwidth=8:tabstop=8:
  *
- * lib/lib-ni.c
- * Network status registers and distance functions.
- *
- *  Copyright (c) 2001-2003 Cluster File Systems, Inc.
- *
  *   This file is part of Lustre, http://www.lustre.org
- *
- *   Lustre is free software; you can redistribute it and/or
- *   modify it under the terms of version 2 of the GNU General Public
- *   License as published by the Free Software Foundation.
- *
- *   Lustre is distributed in the hope that it will be useful,
- *   but WITHOUT ANY WARRANTY; without even the implied warranty of
- *   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *   GNU General Public License for more details.
- *
- *   You should have received a copy of the GNU General Public License
- *   along with Lustre; if not, write to the Free Software
- *   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ *   This file is not subject to copyright protection.
  */
 
 #define DEBUG_SUBSYSTEM S_PORTALS
diff --git a/lnet/lnet/lib-pid.c b/lnet/lnet/lib-pid.c
index 8a9fbc5106e0df87430898dad704e86e6ad89c49..23d6dd3ec023508e8e1f2a654490bfe017234ca9 100644
--- a/lnet/lnet/lib-pid.c
+++ b/lnet/lnet/lib-pid.c
@@ -1,36 +1,13 @@
 /* -*- mode: c; c-basic-offset: 8; indent-tabs-mode: nil; -*-
  * vim:expandtab:shiftwidth=8:tabstop=8:
  *
- * lib/lib-pid.c
- *
- * Process identification routines
- * Copyright (C) 2001-2003 Cluster File Systems, Inc.
- *
  *   This file is part of Lustre, http://www.lustre.org
- *
- *   Lustre is free software; you can redistribute it and/or
- *   modify it under the terms of version 2 of the GNU General Public
- *   License as published by the Free Software Foundation.
- *
- *   Lustre is distributed in the hope that it will be useful,
- *   but WITHOUT ANY WARRANTY; without even the implied warranty of
- *   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *   GNU General Public License for more details.
- *
- *   You should have received a copy of the GNU General Public License
- *   along with Lustre; if not, write to the Free Software
- *   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ *   This file is not subject to copyright protection.
  */
 
 /* This should be removed.  The NAL should have the PID information */
 #define DEBUG_SUBSYSTEM S_PORTALS
 
-#if defined (__KERNEL__)
-extern int getpid(void);
-#else
-#       include <stdio.h>
-#       include <unistd.h>
-#endif
 #include <portals/lib-p30.h>
 
 int