From 316113bbe60da637297a914f336c5f1f81257c6a Mon Sep 17 00:00:00 2001
From: jacob <jacob>
Date: Tue, 3 May 2005 21:46:47 +0000
Subject: [PATCH] b=3031

 - remove .flags files on make clean
---
 build/autoMakefile.am                | 2 +-
 lnet/klnds/gmlnd/autoMakefile.am     | 2 +-
 lnet/klnds/iiblnd/autoMakefile.am    | 2 +-
 lnet/klnds/lolnd/autoMakefile.am     | 2 +-
 lnet/klnds/openiblnd/autoMakefile.am | 2 +-
 lnet/klnds/qswlnd/autoMakefile.am    | 2 +-
 lnet/klnds/ralnd/autoMakefile.am     | 2 +-
 lnet/klnds/socklnd/autoMakefile.am   | 2 +-
 lnet/klnds/viblnd/autoMakefile.am    | 2 +-
 lnet/lnet/autoMakefile.am            | 2 +-
 lnet/router/autoMakefile.am          | 2 +-
 lnet/tests/autoMakefile.am           | 2 +-
 12 files changed, 12 insertions(+), 12 deletions(-)

diff --git a/build/autoMakefile.am b/build/autoMakefile.am
index e101bef711..ad51592dba 100644
--- a/build/autoMakefile.am
+++ b/build/autoMakefile.am
@@ -10,7 +10,7 @@ EXTRA_DIST := Makefile Makefile.in.toplevel		       \
 
 CONFIG_CLEAN_FILES := lustre.spec
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags .*.flags *.o *.ko *.mod.c
 
 distclean: distclean-recursive
 	@true
diff --git a/lnet/klnds/gmlnd/autoMakefile.am b/lnet/klnds/gmlnd/autoMakefile.am
index d8b9edbfa8..f09d65888b 100644
--- a/lnet/klnds/gmlnd/autoMakefile.am
+++ b/lnet/klnds/gmlnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kgmnal-objs:%.o=%.c) gmnal.h
diff --git a/lnet/klnds/iiblnd/autoMakefile.am b/lnet/klnds/iiblnd/autoMakefile.am
index 251df66013..e60af1aaf3 100644
--- a/lnet/klnds/iiblnd/autoMakefile.am
+++ b/lnet/klnds/iiblnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kiibnal-objs:%.o=%.c) iibnal.h
diff --git a/lnet/klnds/lolnd/autoMakefile.am b/lnet/klnds/lolnd/autoMakefile.am
index ee6aa98ccb..c09dcacd26 100644
--- a/lnet/klnds/lolnd/autoMakefile.am
+++ b/lnet/klnds/lolnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(klonal-objs:%.o=%.c) lonal.h
diff --git a/lnet/klnds/openiblnd/autoMakefile.am b/lnet/klnds/openiblnd/autoMakefile.am
index a4207ae080..1da4988361 100644
--- a/lnet/klnds/openiblnd/autoMakefile.am
+++ b/lnet/klnds/openiblnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kopenibnal-objs:%.o=%.c) openibnal.h
diff --git a/lnet/klnds/qswlnd/autoMakefile.am b/lnet/klnds/qswlnd/autoMakefile.am
index b5b2e07b3f..21d717b6c3 100644
--- a/lnet/klnds/qswlnd/autoMakefile.am
+++ b/lnet/klnds/qswlnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kqswnal-objs:%.o=%.c) qswnal.h
diff --git a/lnet/klnds/ralnd/autoMakefile.am b/lnet/klnds/ralnd/autoMakefile.am
index f136aa516f..2828d48dd7 100644
--- a/lnet/klnds/ralnd/autoMakefile.am
+++ b/lnet/klnds/ralnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kranal-objs:%.o=%.c) ranal.h
diff --git a/lnet/klnds/socklnd/autoMakefile.am b/lnet/klnds/socklnd/autoMakefile.am
index 5fc3fc741f..c7a1ae4678 100644
--- a/lnet/klnds/socklnd/autoMakefile.am
+++ b/lnet/klnds/socklnd/autoMakefile.am
@@ -29,4 +29,4 @@ endif # DARWIN
 EXTRA_DIST := $(plist_DATA)
 install-data-hook: $(install_data_hook)
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c socknal_lib.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c socknal_lib.c
diff --git a/lnet/klnds/viblnd/autoMakefile.am b/lnet/klnds/viblnd/autoMakefile.am
index 6d5de4c0e5..6db28b3185 100644
--- a/lnet/klnds/viblnd/autoMakefile.am
+++ b/lnet/klnds/viblnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kvibnal-objs:%.o=%.c) vibnal.h vibnal_wire.h
diff --git a/lnet/lnet/autoMakefile.am b/lnet/lnet/autoMakefile.am
index affce6ee56..b8d9aec424 100644
--- a/lnet/lnet/autoMakefile.am
+++ b/lnet/lnet/autoMakefile.am
@@ -42,5 +42,5 @@ install-data-hook: $(install_data_hook)
 
 EXTRA_DIST := Info.plist
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c portals
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c portals
 DIST_SOURCES = $(portals-objs:%.o=%.c)
diff --git a/lnet/router/autoMakefile.am b/lnet/router/autoMakefile.am
index 08db5930ba..699bd808ab 100644
--- a/lnet/router/autoMakefile.am
+++ b/lnet/router/autoMakefile.am
@@ -13,5 +13,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
 DIST_SOURCES = $(kptlrouter-objs:%.o=%.c) router.h
diff --git a/lnet/tests/autoMakefile.am b/lnet/tests/autoMakefile.am
index 91be8533ff..426105d7c0 100644
--- a/lnet/tests/autoMakefile.am
+++ b/lnet/tests/autoMakefile.am
@@ -16,5 +16,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c pingsrv.c pingcli.c spingsrv.c spingcli.c
+MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c pingsrv.c pingcli.c spingsrv.c spingcli.c
 DIST_SOURCES = ping_srv.c ping_cli.c sping_srv.c sping_cli.c ping.h
-- 
GitLab