diff --git a/lustre/scripts/lustre.spec.in b/lustre/scripts/lustre.spec.in
index 1b2ba019b21bbd4af966389a6680144aa77df134..cd5fb58e1c89b5dd884059f3e77a11c45ec6bd58 100644
--- a/lustre/scripts/lustre.spec.in
+++ b/lustre/scripts/lustre.spec.in
@@ -1,5 +1,5 @@
 # lustre.spec
-%define version b_devel
+%define version HEAD
 %define kversion @LINUXRELEASE@
 %define linuxdir @LINUX@
 
@@ -101,10 +101,11 @@ mkdir -p $RPM_BUILD_ROOT/var/lib/ldap/lustre
 %attr(-, root, root) /usr/sbin/lconf
 %attr(-, root, root) /usr/sbin/lactive
 %attr(-, root, root) /usr/sbin/llanalyze
-%attr(-, root, root) /usr/sbin/lfind
-%attr(-, root, root) /usr/sbin/lstripe
-%attr(-, root, root) /usr/sbin/mcreate
-%attr(-, root, root) /usr/sbin/mkdirmany
+%attr(-, root, root) /usr/bin/lfind
+%attr(-, root, root) /usr/bin/lstripe
+%attr(-, root, root) /usr/bin/mcreate
+%attr(-, root, root) /usr/bin/munlink
+%attr(-, root, root) /usr/bin/mkdirmany
 %attr(-, root, root) /usr/sbin/llstat.pl
 %attr(-, root, root) /usr/sbin/llobdstat.pl
 %attr(-, root, root) /usr/sbin/load_ldap.sh
diff --git a/lustre/scripts/version_tag.pl b/lustre/scripts/version_tag.pl
index f33443f59fc3e504bff429a5eb16c9e85b143b05..334d2d6737e91db38c81f25236b8e46a267b37dc 100644
--- a/lustre/scripts/version_tag.pl
+++ b/lustre/scripts/version_tag.pl
@@ -9,13 +9,27 @@ use Time::Local;
 my $pristine = 1;
 my $kernver;
 
+# Use the CVS tag first otherwise use the portals version
 sub get_tag()
 {
     my $tag;
+    my $line;
 
     my $tagfile = new IO::File;
     if (!$tagfile->open("CVS/Tag")) {
-        return "HEAD";
+        my $verfile = new IO::File;
+        if (!$verfile->open("portals/include/config.h")) {
+          return "UNKNOWN";
+        }
+        while(defined($line = <$verfile>)) {
+            $line =~ /\#define VERSION "(.*)"/;
+            if ($1) {
+                $tag = $1;
+                last;
+            }
+        }
+        $verfile->close();
+        return $tag
     } else {
         my $tmp = <$tagfile>;
         $tagfile->close();
diff --git a/lustre/tests/Makefile.am b/lustre/tests/Makefile.am
index 6600962be3c68e738853e22d85128df0a93b5032..31e33a361f05c961c17e4c02521ad64e810194cc 100644
--- a/lustre/tests/Makefile.am
+++ b/lustre/tests/Makefile.am
@@ -20,7 +20,7 @@ noinst_PROGRAMS += opendirunlink opendevunlink unlinkmany fchdir_test checkstat
 noinst_PROGRAMS += wantedi statone runas openfile getdents mkdirdeep o_directory
 noinst_PROGRAMS += small_write
 # noinst_PROGRAMS += ldaptest
-sbin_PROGRAMS = mcreate munlink mkdirmany
+bin_PROGRAMS = mcreate munlink mkdirmany
 
 # ldaptest_SOURCES = ldaptest.c
 tchmod_SOURCES = tchmod.c
diff --git a/lustre/utils/Makefile.am b/lustre/utils/Makefile.am
index 02da299af1b7c28f40ccf7789bba01ccaeccb0dd..d09ecc22849f9e17cf985dcaece7d6d7954010d7 100644
--- a/lustre/utils/Makefile.am
+++ b/lustre/utils/Makefile.am
@@ -7,7 +7,8 @@ KFLAGS:=
 CPPFLAGS = $(HAVE_LIBREADLINE)
 lctl_LDADD := $(LIBREADLINE) -lptlctl
 lload_LDADD := -lptlctl
-sbin_PROGRAMS = lctl lfind lstripe obdio obdbarrier lload wirecheck
+bin_PROGRAMS = lfind lstripe
+sbin_PROGRAMS = lctl obdio obdbarrier lload wirecheck
 sbin_SCRIPTS = lconf lmc llanalyze llstat.pl llobdstat.pl lactive load_ldap.sh
 wirecheck_SOURCES = wirecheck.c
 lctl_SOURCES = parser.c obd.c lctl.c parser.h obdctl.h