diff --git a/lustre.spec.in b/lustre.spec.in
index e844ab72b189ed61fed30e0a00116aba55bc4949..36f7d463092ca402fb953a8ed9ca8f27caaae44c 100644
--- a/lustre.spec.in
+++ b/lustre.spec.in
@@ -138,7 +138,7 @@ cat >lustre.files <<EOF
 
 %attr(-, root, root) %{_mandir}/man?/*
 
-%attr(-, root, root) %{_libexecdir}/lustre/lc_common
+%attr(-, root, root) %{_libdir}/lustre/lc_common
 EOF
 
 if [ -f $RPM_BUILD_ROOT%{_libdir}/liblustre.so ] ; then
diff --git a/lustre/scripts/Makefile.am b/lustre/scripts/Makefile.am
index 031a9889b580e40cfb4ee046120a424fe901ac7c..f0a44a33e4ca7ad55b8da3670a6064b5e35a6ab4 100644
--- a/lustre/scripts/Makefile.am
+++ b/lustre/scripts/Makefile.am
@@ -15,7 +15,7 @@ EXTRA_DIST = license-status maketags.sh version_tag.pl.in lc_common \
 	     $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
 	     $(bin_SCRIPTS)
 
-scriptlibdir = @libexecdir@/@PACKAGE@
+scriptlibdir = $(libdir)/@PACKAGE@
 scriptlib_DATA = lc_common
 
 CLEANFILES = $(genscripts)