diff --git a/Documentation/lfsck.txt b/Documentation/lfsck.txt
index 7e589738f3528eca483835cfc1d06c8f07235f86..f4e280f3bc35a3bde15c61bba69be00820625dd4 100644
--- a/Documentation/lfsck.txt
+++ b/Documentation/lfsck.txt
@@ -184,7 +184,7 @@ Glossary of terms
 ===============================================
 
 OSD - Object storage device. A generic term for a storage device with an
-  interface that extends beyond a block-orientated device interface.
+  interface that extends beyond a block-oriented device interface.
 
 OI - Object Index. A table that maps FIDs to inodes. This table must be
   regenerated if a file level restore is performed as inodes will change.
diff --git a/config/lustre-build.m4 b/config/lustre-build.m4
index 3963c3b9379a1a2b5ba9b2d4747c5afb8bec3a75..0bae36a5ecf1ea25463763b36905257b34f6461c 100644
--- a/config/lustre-build.m4
+++ b/config/lustre-build.m4
@@ -434,7 +434,7 @@ AS_IF([test x$target_cpu = "xx86_64" -a x$target_vendor != "xk1om"],
 LIBCFS_CONDITIONALS
 LN_CONDITIONALS
 LC_CONDITIONALS
-]) # LB_CONTITIONALS
+]) # LB_CONDITIONALS
 
 #
 # LB_CONFIG_FILES
diff --git a/debian/rules b/debian/rules
index f9df4410549461365474f37e95320f0709cf9d61..7fe36a299618cea7896d447042a2021c72a757fa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,7 +28,7 @@ endif
 #CC?=gcc-3.3
 #export CC
 
-# This is the debhelper compatability version to use.
+# This is the debhelper compatibility version to use.
 export DH_COMPAT=7
 
 # Module-assistant stuff
diff --git a/lnet/klnds/gnilnd/gni_pub.h b/lnet/klnds/gnilnd/gni_pub.h
index 6046cb99582209e1ae9d63032b94e83b95d748a0..5d868274fa3e443372e48a4d8c52811fbdc4f11e 100644
--- a/lnet/klnds/gnilnd/gni_pub.h
+++ b/lnet/klnds/gnilnd/gni_pub.h
@@ -3326,8 +3326,8 @@ gni_return_t
  * Description:
  * This functions sets the maximum retransmit counts for SMSG transactions.
  * EPs associated with the NIC handle provided will give up retransmitting SMSG
- * transactions and return GNI_RC_TRANSACION_ERROR when the retransmit count has
- * been reached.
+ * transactions and return GNI_RC_TRANSACTION_ERROR when the retransmit count
+ * has been reached.
  **/
 gni_return_t
 	GNI_SmsgSetMaxRetrans(
@@ -5315,8 +5315,8 @@ gni_return_t
  * Description:
  * This functions sets the maximum retransmit counts for SMSG transactions.
  * EPs associated with the NIC handle provided will give up retransmitting SMSG
- * transactions and return GNI_RC_TRANSACION_ERROR when the retransmit count has
- * been reached.
+ * transactions and return GNI_RC_TRANSACTION_ERROR when the retransmit count
+ * has been reached.
  **/
 gni_return_t
 	gni_smsg_set_max_retrans(
diff --git a/lnet/klnds/socklnd/socklnd_cb.c b/lnet/klnds/socklnd/socklnd_cb.c
index 7879b4767f539801ed182d79d0458e7f2e0230e3..df18aa5a5292f20aa75ace1a52715d1e59aa079e 100644
--- a/lnet/klnds/socklnd/socklnd_cb.c
+++ b/lnet/klnds/socklnd/socklnd_cb.c
@@ -1115,8 +1115,8 @@ ksocknal_process_receive (ksock_conn_t *conn)
 
 	LASSERT (atomic_read(&conn->ksnc_conn_refcount) > 0);
 
-        /* NB: sched lock NOT held */
-        /* SOCKNAL_RX_LNET_HEADER is here for backward compatability */
+	/* NB: sched lock NOT held */
+	/* SOCKNAL_RX_LNET_HEADER is here for backward compatibility */
         LASSERT (conn->ksnc_rx_state == SOCKNAL_RX_KSM_HEADER ||
                  conn->ksnc_rx_state == SOCKNAL_RX_LNET_PAYLOAD ||
                  conn->ksnc_rx_state == SOCKNAL_RX_LNET_HEADER ||
diff --git a/lnet/klnds/socklnd/socklnd_proto.c b/lnet/klnds/socklnd/socklnd_proto.c
index 5612abcc98697feff2b4aa8f523584cd80d5bcdd..914da566b427dc62a414325839cc10cc6d30cb43 100644
--- a/lnet/klnds/socklnd/socklnd_proto.c
+++ b/lnet/klnds/socklnd/socklnd_proto.c
@@ -219,7 +219,7 @@ ksocknal_queue_tx_zcack_v3(ksock_conn_t *conn,
         if (tx->tx_msg.ksm_zc_cookies[0] > tx->tx_msg.ksm_zc_cookies[1]) {
                 __u64   tmp = 0;
 
-                /* two seperated cookies: (a+2, a) or (a+1, a) */
+		/* two separated cookies: (a+2, a) or (a+1, a) */
                 LASSERT (tx->tx_msg.ksm_zc_cookies[0] -
                          tx->tx_msg.ksm_zc_cookies[1] <= 2);
 
diff --git a/lnet/lnet/config.c b/lnet/lnet/config.c
index 1b8fc3c9f7f062561dc1c5f4d2abe32295b5a70f..4f338ccf3a42282db42c8fe71ef3065b3b3fd2b1 100644
--- a/lnet/lnet/config.c
+++ b/lnet/lnet/config.c
@@ -327,7 +327,7 @@ lnet_parse_networks(struct list_head *nilist, char *networks)
 				goto failed;
 			}
 
-			/* Allocate a seperate piece of memory and copy
+			/* Allocate a separate piece of memory and copy
 			 * into it the string, so we don't have
 			 * a depencency on the tokens string.  This way we
 			 * can free the tokens at the end of the function.
diff --git a/lnet/utils/cyaml/cyaml.c b/lnet/utils/cyaml/cyaml.c
index cb2bf834f66fdea742dae236253d5d56f7e9ccde..31283d8b1fdf13664b28ff2bb50f42491989ec20 100644
--- a/lnet/utils/cyaml/cyaml.c
+++ b/lnet/utils/cyaml/cyaml.c
@@ -1113,7 +1113,7 @@ struct cYAML *cYAML_build_tree(char *yaml_file,
 	/* Create the Parser object. */
 	yaml_parser_initialize(&parser);
 
-	/* file alwyas takes precedence */
+	/* file always takes precedence */
 	if (yaml_file != NULL) {
 		/* Set a file input. */
 		input = fopen(yaml_file, "rb");
diff --git a/lustre/ChangeLog b/lustre/ChangeLog
index d6321644a374d5fa8482b7172286d614dfbfdadc..3d0563955af85e5d3bfeebad04b9953046e0d392 100644
--- a/lustre/ChangeLog
+++ b/lustre/ChangeLog
@@ -460,7 +460,7 @@ Description: Remove set_info(KEY_UNLINKED) from MDS/OSC
 Severity   : enhancement
 Bugzilla   : 19526
 Description: correctly handle big reply message.
-Details    : send LNet event if reply is bigger then buffer and adjust this buffer
+Details    : send LNet event if reply is bigger than buffer and adjust this buffer
              correctly.
 
 Severity   : normal
@@ -2727,7 +2727,7 @@ Severity   : normal
 Bugzilla   : 19128
 Description: Out or order replies might be lost on replay
 Details    : In ptlrpc_retain_replayable_request if we cannot find retained
-             request with tid smaller then one currently being added, add it
+             request with tid smaller than one currently being added, add it
 	     to the start, not end of the list.
 
 --------------------------------------------------------------------------------
diff --git a/lustre/llite/vvp_io.c b/lustre/llite/vvp_io.c
index 0632084290b3faaf9697ce54fb1a7f897c2fd886..1fae4022be5c112ae0ff9000c0f13c1bba449439 100644
--- a/lustre/llite/vvp_io.c
+++ b/lustre/llite/vvp_io.c
@@ -320,7 +320,7 @@ static void vvp_io_fini(const struct lu_env *env, const struct cl_io_slice *ios)
 		/* if restore registration failed, no restart,
 		 * we will return -ENODATA */
 		/* The layout will change after restore, so we need to
-		 * block on layout lock hold by the MDT
+		 * block on layout lock held by the MDT
 		 * as MDT will not send new layout in lvb (see LU-3124)
 		 * we have to explicitly fetch it, all this will be done
 		 * by ll_layout_refresh()
diff --git a/lustre/lod/lod_qos.c b/lustre/lod/lod_qos.c
index 7ee3d332814d5fbbb69e11096933197e06ffe9d0..d447d3141c30091b7d9b17fd57fb8c364680712f 100644
--- a/lustre/lod/lod_qos.c
+++ b/lustre/lod/lod_qos.c
@@ -826,7 +826,7 @@ static int lod_qos_is_ost_used(const struct lu_env *env, int ost, __u32 stripes)
 }
 
 /**
- * Allocate a striping using round-robin algorigthm.
+ * Allocate a striping using round-robin algorithm.
  *
  * Allocates a new striping using round-robin algorithm. The function refreshes
  * all the internal structures (statfs cache, array of available OSTs sorted
@@ -981,7 +981,7 @@ repeat_find:
 		}
 
 		/*
-		 * We've successfuly declared (reserved) an object
+		 * We've successfully declared (reserved) an object
 		 */
 		lod_qos_ost_in_use(env, stripe_idx, ost_idx);
 		stripe[stripe_idx] = o;
@@ -1107,7 +1107,7 @@ static int lod_alloc_ost_list(const struct lu_env *env,
 		}
 
 		/*
-		 * We've successfuly declared (reserved) an object
+		 * We've successfully declared (reserved) an object
 		 */
 		lod_qos_ost_in_use(env, stripe_count, ost_idx);
 		stripe[stripe_count] = o;
@@ -1233,7 +1233,7 @@ repeat_find:
 		}
 
 		/*
-		 * We've successfuly declared (reserved) an object
+		 * We've successfully declared (reserved) an object
 		 */
 		lod_qos_ost_in_use(env, stripe_num, ost_idx);
 		stripe[stripe_num] = o;
diff --git a/lustre/lov/lov_pool.c b/lustre/lov/lov_pool.c
index 1d6360e1a241e41545ed20e0204a8c545c8f45db..b808d585cb6311fe2a1b2fa47caf5de18fb5f614 100644
--- a/lustre/lov/lov_pool.c
+++ b/lustre/lov/lov_pool.c
@@ -458,18 +458,18 @@ int lov_pool_new(struct obd_device *obd, char *poolname)
 	INIT_HLIST_NODE(&new_pool->pool_hash);
 
 #ifdef CONFIG_PROC_FS
-        /* we need this assert seq_file is not implementated for liblustre */
-        /* get ref for /proc file */
+	/* get ref for /proc file */
         lov_pool_getref(new_pool);
-        new_pool->pool_proc_entry = lprocfs_add_simple(lov->lov_pool_proc_entry,
-							poolname, new_pool,
-							&pool_proc_operations);
-        if (IS_ERR(new_pool->pool_proc_entry)) {
-                CWARN("Cannot add proc pool entry "LOV_POOLNAMEF"\n", poolname);
-                new_pool->pool_proc_entry = NULL;
-                lov_pool_putref(new_pool);
-        }
-        CDEBUG(D_INFO, "pool %p - proc %p\n", new_pool, new_pool->pool_proc_entry);
+	new_pool->pool_proc_entry = lprocfs_add_simple(lov->lov_pool_proc_entry,
+						       poolname, new_pool,
+						       &pool_proc_operations);
+	if (IS_ERR(new_pool->pool_proc_entry)) {
+		CWARN("Cannot add proc pool entry "LOV_POOLNAMEF"\n", poolname);
+		new_pool->pool_proc_entry = NULL;
+		lov_pool_putref(new_pool);
+	}
+	CDEBUG(D_INFO, "pool %p - proc %p\n",
+	       new_pool, new_pool->pool_proc_entry);
 #endif
 
 	spin_lock(&obd->obd_dev_lock);
diff --git a/lustre/mdc/mdc_request.c b/lustre/mdc/mdc_request.c
index ce1ebbb240ae7efdb8ac96d5bc84c87c7b0ec9c0..64bf18490973cadcd9d4cbc0c28586dce8f0d19a 100644
--- a/lustre/mdc/mdc_request.c
+++ b/lustre/mdc/mdc_request.c
@@ -2083,9 +2083,9 @@ static int mdc_ioc_swap_layouts(struct obd_export *exp,
 
 	/* When the MDT will get the MDS_SWAP_LAYOUTS RPC the
 	 * first thing it will do is to cancel the 2 layout
-	 * locks hold by this client.
+	 * locks held by this client.
 	 * So the client must cancel its layout locks on the 2 fids
-	 * with the request RPC to avoid extra RPC round trips
+	 * with the request RPC to avoid extra RPC round trips.
 	 */
 	count = mdc_resource_get_unused(exp, &op_data->op_fid1, &cancels,
 					LCK_EX, MDS_INODELOCK_LAYOUT |
diff --git a/lustre/mdd/mdd_dir.c b/lustre/mdd/mdd_dir.c
index fe074807936ac42d83c67868ba815eac95a405b4..25f3e7731fa0a1927232c53b512a2d4e995365a6 100644
--- a/lustre/mdd/mdd_dir.c
+++ b/lustre/mdd/mdd_dir.c
@@ -827,7 +827,7 @@ void mdd_changelog_rec_ext_jobid(struct changelog_rec *rec, const char *jobid)
  * \param spfid - source parent fid
  * \param tname - target name string
  * \param sname - source name string
- * \param handle - transacion handle
+ * \param handle - transaction handle
  */
 int mdd_changelog_ns_store(const struct lu_env *env,
 			   struct mdd_device *mdd,
diff --git a/lustre/mdd/mdd_object.c b/lustre/mdd/mdd_object.c
index 35d9fdddfe2dcdcde109c6720876f03aa4c3ecb7..b6c8126440868ef90d58c7a01fea8e2435cd8f59 100644
--- a/lustre/mdd/mdd_object.c
+++ b/lustre/mdd/mdd_object.c
@@ -617,7 +617,7 @@ static int mdd_fix_attr(const struct lu_env *env, struct mdd_object *obj,
  * If this fails, we must fail the whole transaction; we don't
  * want the change to commit without the log entry.
  * \param mdd_obj - mdd_object of change
- * \param handle - transacion handle
+ * \param handle - transaction handle
  */
 int mdd_changelog_data_store(const struct lu_env *env, struct mdd_device *mdd,
 			     enum changelog_rec_type type, int flags,
diff --git a/lustre/mdt/mdt_hsm_cdt_agent.c b/lustre/mdt/mdt_hsm_cdt_agent.c
index 5c099eb8c8e646fd67d8e66c3f66115dda8e0d3c..4ef5f148883523e5be5f089ce46cca8870138784 100644
--- a/lustre/mdt/mdt_hsm_cdt_agent.c
+++ b/lustre/mdt/mdt_hsm_cdt_agent.c
@@ -49,7 +49,7 @@
 
 /*
  * find a hsm_agent by uuid
- * lock cdt_agent_lock needs to be hold by caller
+ * lock cdt_agent_lock needs to be held by caller
  * \param cdt [IN] coordinator
  * \param uuid [IN] agent UUID
  * \retval hsm_agent pointer or NULL if not found
diff --git a/lustre/mdt/mdt_hsm_cdt_requests.c b/lustre/mdt/mdt_hsm_cdt_requests.c
index 36adeb19cf563ba66292db0168d98687817f0e8a..bbd7f44b98f38e7e89e25129a7cd7fd9564136e2 100644
--- a/lustre/mdt/mdt_hsm_cdt_requests.c
+++ b/lustre/mdt/mdt_hsm_cdt_requests.c
@@ -300,7 +300,7 @@ void mdt_cdt_put_request(struct cdt_agent_req *car)
 
 /**
  * find request in the list by cookie or by fid
- * lock cdt_request_lock needs to be hold by caller
+ * lock cdt_request_lock needs to be held by caller
  * \param cdt [IN] coordinator
  * \param cookie [IN] request cookie
  * \param fid [IN] fid
diff --git a/lustre/obdclass/obd_mount.c b/lustre/obdclass/obd_mount.c
index bf07a87b1894d8b77ce255f9d0898c8156d66d8c..4f247c3f02812388390ebbe65ed28fd0ff6359a9 100644
--- a/lustre/obdclass/obd_mount.c
+++ b/lustre/obdclass/obd_mount.c
@@ -664,10 +664,10 @@ int lustre_put_lsi(struct super_block *sb)
 }
 
 /*** SERVER NAME ***
- * <FSNAME><SEPERATOR><TYPE><INDEX>
+ * <FSNAME><SEPARATOR><TYPE><INDEX>
  * FSNAME is between 1 and 8 characters (inclusive).
  *	Excluded characters are '/' and ':'
- * SEPERATOR is either ':' or '-'
+ * SEPARATOR is either ':' or '-'
  * TYPE: "OST", "MDT", etc.
  * INDEX: Hex representation of the index
  */
diff --git a/lustre/obdecho/echo_client.c b/lustre/obdecho/echo_client.c
index 3aa77596ce905811f24e322a33145ef66ba52c8f..c117b7aa95c3c075710764b81e4d139d2dbe3267 100644
--- a/lustre/obdecho/echo_client.c
+++ b/lustre/obdecho/echo_client.c
@@ -598,10 +598,10 @@ static int echo_site_init(const struct lu_env *env, struct echo_device *ed)
         struct cl_site *site = &ed->ed_site_myself;
         int rc;
 
-        /* initialize site */
+	/* initialize site */
         rc = cl_site_init(site, &ed->ed_cl);
         if (rc) {
-                CERROR("Cannot initilize site for echo client(%d)\n", rc);
+		CERROR("Cannot initialize site for echo client(%d)\n", rc);
                 return rc;
         }
 
diff --git a/lustre/osc/osc_cache.c b/lustre/osc/osc_cache.c
index 48a43f301d8de0402ff8668ce639893dcd27bc17..66e08b72e7ea96542c8038f96c08a43d302eb24b 100644
--- a/lustre/osc/osc_cache.c
+++ b/lustre/osc/osc_cache.c
@@ -964,7 +964,7 @@ static int osc_extent_truncate(struct osc_extent *ext, pgoff_t trunc_index,
 	if (rc < 0)
 		GOTO(out, rc);
 
-	/* discard all pages with index greater then trunc_index */
+	/* discard all pages with index greater than trunc_index */
 	list_for_each_entry_safe(oap, tmp, &ext->oe_pages,
 				     oap_pending_item) {
 		pgoff_t index = osc_index(oap2osc(oap));
diff --git a/lustre/osp/osp_md_object.c b/lustre/osp/osp_md_object.c
index caa7ee9f4ca83c659984ef12cf8abeef89443655..3acbb161e3f8d0909e369ea3ae5aa4dc63b42274 100644
--- a/lustre/osp/osp_md_object.c
+++ b/lustre/osp/osp_md_object.c
@@ -697,7 +697,7 @@ static int osp_md_index_delete(const struct lu_env *env,
  * \param[in] env	execution environment
  * \param[in] di	iterator of this iteration
  *
- * \retval		0 if the pointer is advanced successfuly.
+ * \retval		0 if the pointer is advanced successfully.
  * \retval		1 if it reaches to the end of the index object.
  * \retval		negative errno if the pointer cannot be advanced.
  */
diff --git a/lustre/osp/osp_precreate.c b/lustre/osp/osp_precreate.c
index ec64dae75d325baa2cb5caf7720f22dede7db7b8..3c4d3c81d1df21211577c0049a98025886e470d7 100644
--- a/lustre/osp/osp_precreate.c
+++ b/lustre/osp/osp_precreate.c
@@ -217,7 +217,7 @@ static int osp_statfs_update(struct osp_device *d)
  *
  * If cached statfs data claim no free space, but OSP has got a request to
  * destroy an object (so release some space probably), then we may need to
- * refresh cached statfs data sooner then planned. The function checks there
+ * refresh cached statfs data sooner than planned. The function checks there
  * is no statfs update going and schedules immediate update if so.
  * XXX: there might be a case where removed object(s) do not add free space (empty
  * object). If the number of such deletions is high, then we can start to update
diff --git a/lustre/ptlrpc/gss/gss_pipefs.c b/lustre/ptlrpc/gss/gss_pipefs.c
index c7175291d49ff9c6a9cae48932fe8cdecc62208d..eec4c8d977066c041e41643cf114073a38a631ee 100644
--- a/lustre/ptlrpc/gss/gss_pipefs.c
+++ b/lustre/ptlrpc/gss/gss_pipefs.c
@@ -85,7 +85,7 @@ static void gss_sec_pipe_upcall_fini(struct gss_sec *gsec)
 }
 
 /****************************************
- * internel context helpers             *
+ * internal context helpers             *
  ****************************************/
 
 static
diff --git a/lustre/ptlrpc/service.c b/lustre/ptlrpc/service.c
index 6229a6f6e7330c6b35229baba9bec0a4ba47b392..5098c108e5c2d4cb7cb8bc56b2d1d5370a71e2d8 100644
--- a/lustre/ptlrpc/service.c
+++ b/lustre/ptlrpc/service.c
@@ -554,7 +554,7 @@ ptlrpc_server_nthreads_check(struct ptlrpc_service *svc,
 
 		/*
 		 * User wants to increase number of threads with for
-		 * each CPU core/HT, most likely the factor is larger then
+		 * each CPU core/HT, most likely the factor is larger than
 		 * one thread/core because service threads are supposed to
 		 * be blocked by lock or wait for IO.
 		 */
diff --git a/lustre/utils/l_getidentity.c b/lustre/utils/l_getidentity.c
index 9f357a453c4b6cf5082dab092225f165ca8296e4..94956437bf67825be3927cb9fddd68e3e6937f2f 100644
--- a/lustre/utils/l_getidentity.c
+++ b/lustre/utils/l_getidentity.c
@@ -65,7 +65,7 @@
  * the valid values for perms are:
  * setuid/setgid/setgrp/rmtacl           -- enable corresponding perm
  * nosetuid/nosetgid/nosetgrp/normtacl   -- disable corresponding perm
- * they can be listed together, seperated by ',',
+ * they can be listed together, separated by ',',
  * when perm and noperm are in the same line (item), noperm is preferential,
  * when they are in different lines (items), the latter is preferential,
  * '*' nid is as default perm, and is not preferential.
diff --git a/lustre/utils/liblustreapi.c b/lustre/utils/liblustreapi.c
index a16257dfb1a9dc294c05e90847dacb42f0d33a12..46e361361015683c5288253b38e05a3a7f4e04fb 100644
--- a/lustre/utils/liblustreapi.c
+++ b/lustre/utils/liblustreapi.c
@@ -1376,7 +1376,7 @@ int llapi_get_poollist(const char *name, char **poollist, int list_size,
         unsigned int used = 0;
         unsigned int i;
 
-        /* initilize output array */
+	/* initialize output array */
         for (i = 0; i < list_size; i++)
                 poollist[i] = NULL;
 
@@ -2365,7 +2365,7 @@ static void lov_dump_user_lmm_header(struct lov_user_md *lum, char *path,
                                      int raw, char *pool_name)
 {
         char *prefix = is_dir ? "" : "lmm_";
-	char *seperator = "";
+	char *separator = "";
         int rc;
 
 	if (is_dir && lmm_oi_seq(&lum->lmm_oi) == FID_SEQ_LOV_DEFAULT) {
@@ -2413,11 +2413,11 @@ static void lov_dump_user_lmm_header(struct lov_user_md *lum, char *path,
 			llapi_printf(LLAPI_MSG_NORMAL, "%hd",
 				     (__s16)lum->lmm_stripe_count);
                 }
-		seperator = is_dir ? " " : "\n";
+		separator = is_dir ? " " : "\n";
         }
 
         if (verbose & VERBOSE_SIZE) {
-		llapi_printf(LLAPI_MSG_NORMAL, "%s", seperator);
+		llapi_printf(LLAPI_MSG_NORMAL, "%s", separator);
                 if (verbose & ~VERBOSE_SIZE)
                         llapi_printf(LLAPI_MSG_NORMAL, "%sstripe_size:    ",
                                      prefix);
@@ -2435,30 +2435,30 @@ static void lov_dump_user_lmm_header(struct lov_user_md *lum, char *path,
 			llapi_printf(LLAPI_MSG_NORMAL, "%u",
 				     lum->lmm_stripe_size);
                 }
-		seperator = is_dir ? " " : "\n";
+		separator = is_dir ? " " : "\n";
         }
 
 	if ((verbose & VERBOSE_LAYOUT) && !is_dir) {
-		llapi_printf(LLAPI_MSG_NORMAL, "%s", seperator);
+		llapi_printf(LLAPI_MSG_NORMAL, "%s", separator);
 		if (verbose & ~VERBOSE_LAYOUT)
 			llapi_printf(LLAPI_MSG_NORMAL, "%spattern:        ",
 				     prefix);
 		llapi_printf(LLAPI_MSG_NORMAL, "%.x", lum->lmm_pattern);
-		seperator = "\n";
+		separator = "\n";
 	}
 
         if ((verbose & VERBOSE_GENERATION) && !is_dir) {
-		llapi_printf(LLAPI_MSG_NORMAL, "%s", seperator);
+		llapi_printf(LLAPI_MSG_NORMAL, "%s", separator);
                 if (verbose & ~VERBOSE_GENERATION)
                         llapi_printf(LLAPI_MSG_NORMAL, "%slayout_gen:     ",
                                      prefix);
 		llapi_printf(LLAPI_MSG_NORMAL, "%u",
 			     (int)lum->lmm_layout_gen);
-		seperator = "\n";
+		separator = "\n";
         }
 
         if (verbose & VERBOSE_OFFSET) {
-		llapi_printf(LLAPI_MSG_NORMAL, "%s", seperator);
+		llapi_printf(LLAPI_MSG_NORMAL, "%s", separator);
                 if (verbose & ~VERBOSE_OFFSET)
                         llapi_printf(LLAPI_MSG_NORMAL, "%sstripe_offset:  ",
                                      prefix);
@@ -2470,11 +2470,11 @@ static void lov_dump_user_lmm_header(struct lov_user_md *lum, char *path,
                 else
 			llapi_printf(LLAPI_MSG_NORMAL, "%u",
 				     objects[0].l_ost_idx);
-		seperator = is_dir ? " " : "\n";
+		separator = is_dir ? " " : "\n";
         }
 
         if ((verbose & VERBOSE_POOL) && (pool_name != NULL)) {
-		llapi_printf(LLAPI_MSG_NORMAL, "%s", seperator);
+		llapi_printf(LLAPI_MSG_NORMAL, "%s", separator);
                 if (verbose & ~VERBOSE_POOL)
                         llapi_printf(LLAPI_MSG_NORMAL, "%spool:           ",
                                      prefix);
diff --git a/snmp/lustre-snmp-trap.c b/snmp/lustre-snmp-trap.c
index ea09d9f6b19001157b0f02cf1444e100dfeef565..c908d4712f8a3d5991de135831fc76d156892ed7 100644
--- a/snmp/lustre-snmp-trap.c
+++ b/snmp/lustre-snmp-trap.c
@@ -123,7 +123,7 @@ static unsigned int g_registration_handle;
 static char *g_health_check_test_file = 0;
 
 /*****************************************************************************
- * Function: initilize_trap_handler
+ * Function: initialize_trap_handler
  *
  * Description: Initlized the trap poll haalder.
  *
@@ -133,7 +133,7 @@ static char *g_health_check_test_file = 0;
  *
  ****************************************************************************/
  
-void initilize_trap_handler(void)
+void initialize_trap_handler(void)
 {
     g_poll_interval_seconds = get_poll_interval_seconds();
 
diff --git a/snmp/lustre-snmp-trap.h b/snmp/lustre-snmp-trap.h
index 1dbfe1b9fd7b969cf4928f8102a6487e927654eb..9f26ead39aa673cddfd0c64f8e319a5d003d7733 100644
--- a/snmp/lustre-snmp-trap.h
+++ b/snmp/lustre-snmp-trap.h
@@ -39,7 +39,7 @@
 #ifndef LUSTRE_SNMP_TRAP_H
 #define LUSTRE_SNMP_TRAP_H
 
-extern void initilize_trap_handler(void);
+extern void initialize_trap_handler(void);
 extern void terminate_trap_handler(void);
 
 #endif
diff --git a/snmp/lustre-snmp.c b/snmp/lustre-snmp.c
index 41070e07f23be55c1f4d0f11d2e7c430b2802998..2c1bcf32ac414d933277d88579f3cc367aa4c927 100644
--- a/snmp/lustre-snmp.c
+++ b/snmp/lustre-snmp.c
@@ -187,13 +187,14 @@ struct variable7 clusterFileSystems_variables[] = {
  
 void init_lustresnmp(void) {
 
-  /* register ourselves with the agent to handle our mib tree */
-  REGISTER_MIB("clusterFileSystems", clusterFileSystems_variables, variable7,
-               clusterFileSystems_variables_oid);
-               
-   initilize_trap_handler();
+	/* register ourselves with the agent to handle our mib tree */
+	REGISTER_MIB("clusterFileSystems",
+		     clusterFileSystems_variables, variable7,
+		     clusterFileSystems_variables_oid);
 
-  DEBUGMSGTL(("lsnmpd", "%s %s \n", __FUNCTION__, "Initialization Done"));
+	initialize_trap_handler();
+
+	DEBUGMSGTL(("lsnmpd", "%s %s\n", __func__, "Initialization Done"));
 }
 
 /*****************************************************************************
@@ -209,13 +210,14 @@ void init_lustresnmp(void) {
 
 void deinit_lustresnmp(void) {
 
-  /* deregister ourselves with the agent */
-  unregister_mib(clusterFileSystems_variables_oid,
-    sizeof(clusterFileSystems_variables_oid)/sizeof(clusterFileSystems_variables_oid));
-  
-  terminate_trap_handler();
-  
-  DEBUGMSGTL(("lsnmpd", "%s %s \n", __FUNCTION__, "Termination Done"));
+	/* deregister ourselves with the agent */
+	unregister_mib(clusterFileSystems_variables_oid,
+		       sizeof(clusterFileSystems_variables_oid)/
+		       sizeof(clusterFileSystems_variables_oid));
+
+	terminate_trap_handler();
+
+	DEBUGMSGTL(("lsnmpd", "%s %s\n", __func__, "Termination Done"));
 }
 
 /*****************************************************************************