From 666c34b951673f6c3b4921d0833a65f9d2f7e379 Mon Sep 17 00:00:00 2001
From: yangsheng <yangsheng>
Date: Sat, 20 Sep 2008 10:36:24 +0000
Subject: [PATCH] Branch b1_6 b=16689 i=brian, yibin.wang

Make change for sles9/ppc64 build.
---
 build/lbuild                    |  2 +-
 build/lmake                     | 10 +++++++---
 build/lustre-kernel-2.4.spec.in |  2 +-
 3 files changed, 9 insertions(+), 5 deletions(-)

diff --git a/build/lbuild b/build/lbuild
index 2485023ecc..2c2340d82b 100755
--- a/build/lbuild
+++ b/build/lbuild
@@ -510,7 +510,7 @@ load_target()
 
     BUILD_ARCHS=
     for arch in $(uniqify "$ALL_ARCHS") ; do
-        if [ -z "$TARGET_ARCHS" ] || echo "$TARGET_ARCHS" | grep "$arch" >/dev/null 2>/dev/null ; then
+        if [ -z "$TARGET_ARCHS" ] || [[ $TARGET_ARCHES =~ (\ |^)$arch(\ |$) ]] ; then
             BUILD_ARCHS="$BUILD_ARCHS $arch"
         fi
     done
diff --git a/build/lmake b/build/lmake
index 0acce675d4..b917687e90 100755
--- a/build/lmake
+++ b/build/lmake
@@ -344,9 +344,13 @@ patch_kernel()
 set_make()
 {
     MAKE="make -s"
-    if [ "$CC" ] ; then
-	MAKE_CC="CC=$CC"
-    fi
+    [ "$CC" ] && {
+        if [ "$TARGET_ARCH" == "ppc64" ] ; then
+                MAKE_CC="CC=$CC -m64"
+        else 
+                MAKE_CC="CC=$CC"
+        fi
+    }
     if [ "$ARCH" ] ; then
 	MAKE_ARCH="$MAKE ARCH=$ARCH"
     else
diff --git a/build/lustre-kernel-2.4.spec.in b/build/lustre-kernel-2.4.spec.in
index b296702715..804e65cc52 100644
--- a/build/lustre-kernel-2.4.spec.in
+++ b/build/lustre-kernel-2.4.spec.in
@@ -154,7 +154,7 @@ Release: %{release}%{?targetboard:%{targetboard}}%{?debuglevel_1:.dbg}
 %define KVERREL %{PACKAGE_VERSION}%{kextraverdelim}%{kextraver}%{?targetboard:%{targetboard}}%{?debuglevel_1:.dbg}
 License: GPL
 Group: System Environment/Kernel
-ExclusiveArch: %{all_x86} x86_64 ia64 ppc
+ExclusiveArch: %{all_x86} x86_64 ia64 ppc ppc64
 ExclusiveOS: Linux
 Obsoletes: kernel-modules, kernel-sparc
 Provides: kernel = %{version}
-- 
GitLab