diff --git a/ldiskfs/kernel_patches/series/ldiskfs-2.6.12-vanilla.series b/ldiskfs/kernel_patches/series/ldiskfs-2.6.12-vanilla.series
index 53c060b352f1784e4089e8482eafe8cfd6744854..286a3a2c0d6a12fd95ea8684d55d14339382a071 100644
--- a/ldiskfs/kernel_patches/series/ldiskfs-2.6.12-vanilla.series
+++ b/ldiskfs/kernel_patches/series/ldiskfs-2.6.12-vanilla.series
@@ -11,5 +11,8 @@ ext3-ialloc-2.6.patch
 ext3-remove-cond_resched-calls-2.6.12.patch
 ext3-htree-dot-2.6.patch
 ext3-external-journal-2.6.12.patch
-ext3-lookup-dotdot-2.6.9.patch
-ext3-sector_t-overflow-2.6.12.patch
+ext3-check-jbd-errors-2.6.12.patch
+ext3-check-jbd-errors-2.6.9.patch
+ext3-uninit-2.6.9.patch
+ext3-nanosecond-2.6-rhel4.patch
+
diff --git a/ldiskfs/ldiskfs/Makefile.in b/ldiskfs/ldiskfs/Makefile.in
index f945ff3de0b43d4ad8de6dad68ca0c762400789c..42f5dd784da38ee2631ece3ca9f585f70b1cf748 100644
--- a/ldiskfs/ldiskfs/Makefile.in
+++ b/ldiskfs/ldiskfs/Makefile.in
@@ -10,7 +10,7 @@ linux_headers := $(wildcard @LINUX@/include/linux/ext3*.h)
 
 ext3_sources := $(filter-out %.mod.c,$(wildcard @LINUX@/fs/ext3/*.c))
 new_sources := iopen.c iopen.h extents.c mballoc.c group.h
-new_headers := ext3_extents.h
+new_headers := ext3_extents.h 
 ldiskfs_patched_sources := $(notdir $(ext3_sources) $(ext3_headers)) $(new_sources) $(new_headers)
 ldiskfs_sources := $(ldiskfs_patched_sources)