From c2b877b6df0cf4ba3c572bcf6c5a25ed2efb2e1c Mon Sep 17 00:00:00 2001
From: jacob <jacob>
Date: Tue, 3 May 2005 22:16:17 +0000
Subject: [PATCH] b=3031

 - this is what i should have done originally
---
 build/autoMakefile.am                | 2 +-
 build/autoconf/lustre-build.m4       | 3 +++
 lnet/klnds/gmlnd/autoMakefile.am     | 2 +-
 lnet/klnds/iiblnd/autoMakefile.am    | 2 +-
 lnet/klnds/lolnd/autoMakefile.am     | 2 +-
 lnet/klnds/openiblnd/autoMakefile.am | 2 +-
 lnet/klnds/qswlnd/autoMakefile.am    | 2 +-
 lnet/klnds/ralnd/autoMakefile.am     | 2 +-
 lnet/klnds/socklnd/autoMakefile.am   | 2 +-
 lnet/klnds/viblnd/autoMakefile.am    | 2 +-
 lnet/libcfs/autoMakefile.am          | 4 ++--
 lnet/lnet/autoMakefile.am            | 2 +-
 lnet/router/autoMakefile.am          | 2 +-
 lnet/tests/autoMakefile.am           | 2 +-
 14 files changed, 17 insertions(+), 14 deletions(-)

diff --git a/build/autoMakefile.am b/build/autoMakefile.am
index e101bef711..15e8a3fceb 100644
--- a/build/autoMakefile.am
+++ b/build/autoMakefile.am
@@ -10,7 +10,7 @@ EXTRA_DIST := Makefile Makefile.in.toplevel		       \
 
 CONFIG_CLEAN_FILES := lustre.spec
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 
 distclean: distclean-recursive
 	@true
diff --git a/build/autoconf/lustre-build.m4 b/build/autoconf/lustre-build.m4
index 90753fd300..77cd0755dd 100644
--- a/build/autoconf/lustre-build.m4
+++ b/build/autoconf/lustre-build.m4
@@ -492,6 +492,9 @@ LC_CONFIG_FILES
 
 AC_SUBST(ac_configure_args)
 
+MOSTLYCLEANFILES='.*.cmd .*.flags *.o *.ko *.mod.c'
+AC_SUBST(MOSTLYCLEANFILES)
+
 AC_OUTPUT
 
 cat <<_ACEOF
diff --git a/lnet/klnds/gmlnd/autoMakefile.am b/lnet/klnds/gmlnd/autoMakefile.am
index f09d65888b..8c3b7c015d 100644
--- a/lnet/klnds/gmlnd/autoMakefile.am
+++ b/lnet/klnds/gmlnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kgmnal-objs:%.o=%.c) gmnal.h
diff --git a/lnet/klnds/iiblnd/autoMakefile.am b/lnet/klnds/iiblnd/autoMakefile.am
index e60af1aaf3..d61ffe75bc 100644
--- a/lnet/klnds/iiblnd/autoMakefile.am
+++ b/lnet/klnds/iiblnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kiibnal-objs:%.o=%.c) iibnal.h
diff --git a/lnet/klnds/lolnd/autoMakefile.am b/lnet/klnds/lolnd/autoMakefile.am
index c09dcacd26..f7d04f7a49 100644
--- a/lnet/klnds/lolnd/autoMakefile.am
+++ b/lnet/klnds/lolnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(klonal-objs:%.o=%.c) lonal.h
diff --git a/lnet/klnds/openiblnd/autoMakefile.am b/lnet/klnds/openiblnd/autoMakefile.am
index 1da4988361..6f564216e8 100644
--- a/lnet/klnds/openiblnd/autoMakefile.am
+++ b/lnet/klnds/openiblnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kopenibnal-objs:%.o=%.c) openibnal.h
diff --git a/lnet/klnds/qswlnd/autoMakefile.am b/lnet/klnds/qswlnd/autoMakefile.am
index 21d717b6c3..228689db74 100644
--- a/lnet/klnds/qswlnd/autoMakefile.am
+++ b/lnet/klnds/qswlnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kqswnal-objs:%.o=%.c) qswnal.h
diff --git a/lnet/klnds/ralnd/autoMakefile.am b/lnet/klnds/ralnd/autoMakefile.am
index 2828d48dd7..3bb7642096 100644
--- a/lnet/klnds/ralnd/autoMakefile.am
+++ b/lnet/klnds/ralnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kranal-objs:%.o=%.c) ranal.h
diff --git a/lnet/klnds/socklnd/autoMakefile.am b/lnet/klnds/socklnd/autoMakefile.am
index c7a1ae4678..71a3633f4a 100644
--- a/lnet/klnds/socklnd/autoMakefile.am
+++ b/lnet/klnds/socklnd/autoMakefile.am
@@ -29,4 +29,4 @@ endif # DARWIN
 EXTRA_DIST := $(plist_DATA)
 install-data-hook: $(install_data_hook)
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c socknal_lib.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@  socknal_lib.c
diff --git a/lnet/klnds/viblnd/autoMakefile.am b/lnet/klnds/viblnd/autoMakefile.am
index 6db28b3185..f90fbf2896 100644
--- a/lnet/klnds/viblnd/autoMakefile.am
+++ b/lnet/klnds/viblnd/autoMakefile.am
@@ -11,5 +11,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kvibnal-objs:%.o=%.c) vibnal.h vibnal_wire.h
diff --git a/lnet/libcfs/autoMakefile.am b/lnet/libcfs/autoMakefile.am
index ea3b47c73f..10ff9012f0 100644
--- a/lnet/libcfs/autoMakefile.am
+++ b/lnet/libcfs/autoMakefile.am
@@ -41,6 +41,6 @@ install-data-hook: $(install_data_hook)
 
 EXTRA_DIST := Info.plist
 
-MOSTLYCLEANFILES := .*.flags *.o *.ko *.mod.c linux-*.c 
-MOSTLYCLEANFILES += linux/*.o darwin/*.o libcfs
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@  linux-*.c 
+MOSTLYCLEANFILES += linux darwin/*.o libcfs
 DIST_SOURCES := $(libcfs-all-objs:%.o=%.c) tracefile.h
diff --git a/lnet/lnet/autoMakefile.am b/lnet/lnet/autoMakefile.am
index b8d9aec424..bd05e93895 100644
--- a/lnet/lnet/autoMakefile.am
+++ b/lnet/lnet/autoMakefile.am
@@ -42,5 +42,5 @@ install-data-hook: $(install_data_hook)
 
 EXTRA_DIST := Info.plist
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c portals
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@  portals
 DIST_SOURCES = $(portals-objs:%.o=%.c)
diff --git a/lnet/router/autoMakefile.am b/lnet/router/autoMakefile.am
index 699bd808ab..070b00824a 100644
--- a/lnet/router/autoMakefile.am
+++ b/lnet/router/autoMakefile.am
@@ -13,5 +13,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
 DIST_SOURCES = $(kptlrouter-objs:%.o=%.c) router.h
diff --git a/lnet/tests/autoMakefile.am b/lnet/tests/autoMakefile.am
index 426105d7c0..f6118680ee 100644
--- a/lnet/tests/autoMakefile.am
+++ b/lnet/tests/autoMakefile.am
@@ -16,5 +16,5 @@ endif
 endif
 endif
 
-MOSTLYCLEANFILES = .*.flags *.o *.ko *.mod.c pingsrv.c pingcli.c spingsrv.c spingcli.c
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@  pingsrv.c pingcli.c spingsrv.c spingcli.c
 DIST_SOURCES = ping_srv.c ping_cli.c sping_srv.c sping_cli.c ping.h
-- 
GitLab