diff --git a/lustre/Makefile.in b/lustre/Makefile.in
index ad621aaf6c47db8cd1c4f39fc522e31953850ff7..311435df956720f41ce729c225dc05ec13ac2920 100644
--- a/lustre/Makefile.in
+++ b/lustre/Makefile.in
@@ -15,13 +15,14 @@ subdir-m += obdfilter
 subdir-m += ost
 subdir-m += llite
 subdir-m += cobd
+subdir-m += smfs
+subdir-m += cmobd 
+ 
 
 ifeq ($(PATCHLEVEL),4)
 subdir-m += ptlbd
 endif # PATCHLEVEL = 4
 
 @SNAPFS_TRUE@subdir-m += snapfs
-@SMFS_TRUE@subdir-m += smfs 
-@SMFS_TRUE@subdir-m += cmobd
 
 @INCLUDE_RULES@
diff --git a/lustre/configure.in b/lustre/configure.in
index c57a7da04b6770af09de44fdcb1921f70f4b1096..3373fd0e05ae7a61d9e1d3222e70aad2079b23f3 100644
--- a/lustre/configure.in
+++ b/lustre/configure.in
@@ -146,15 +146,6 @@ AC_ARG_ENABLE([snapfs],
 AC_MSG_RESULT([$enable_snapfs])
 AM_CONDITIONAL(SNAPFS, test x$enable_snapfs = xyes)
 
-# smfs compilation
-AC_MSG_CHECKING([whether to enable smfs support])
-AC_ARG_ENABLE([smfs],
-	AC_HELP_STRING([--enable-smfs],
-			[build smfs]),
-	[],[enable_smfs='no'])
-AC_MSG_RESULT([$enable_smfs])
-AM_CONDITIONAL(SMFS, test x$enable_smfs = xyes)
-
 sinclude(portals/build.m4)
 sinclude(portals/archdep.m4)
 
diff --git a/lustre/smfs/autoMakefile.am b/lustre/smfs/autoMakefile.am
index 952cfa77944cd76208851d48925719f7dc136d32..b93a4abde0ec05cfb3ca3d23f2db1e0cf45386ef 100644
--- a/lustre/smfs/autoMakefile.am
+++ b/lustre/smfs/autoMakefile.am
@@ -3,9 +3,7 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-if SMFS
 modulefs_DATA = smfs$(KMODEXT)
-endif
 
 MOSTLYCLEANFILES = *.o *.ko *.mod.c
 DIST_SOURCES = $(smfs-objs:%.o=%.c) smfs_internal.h