diff --git a/build/autogen.sh b/build/autogen.sh
index 5d77897f135fb43580f9eeb21046f6d9d8b61ad9..71c05e461398d2d6c6c43abbed9ee36b61866e16 100644
--- a/build/autogen.sh
+++ b/build/autogen.sh
@@ -31,7 +31,7 @@ error_msg() {
 		EOF
 	else
 		cat >&2 <<-EOF
-		CFS provides RPMs which can be installed alongside your
+		Sun provides RPMs which can be installed alongside your
 		existing autoconf/make RPMs, if you are nervous about
 		upgrading.  See
 
diff --git a/build/kabi b/build/kabi
index a57a46c1f2e4db3cd1eedfeace47823e40a032bf..6a134d54f9705983612f8d0c31de887a0cece583 100755
--- a/build/kabi
+++ b/build/kabi
@@ -1,7 +1,8 @@
 #! /usr/bin/perl
 # kabi - Linux Kernel Application Binary Interface manager
-# Copyright (C) 2005  Cluster File Systems, Inc.
-# All rights reserved.
+#
+# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Use is subject to license terms.
 #
 # Gordon Matzigkeit <gord@clusterfs.com>, 2005-10-21
 
@@ -50,7 +51,7 @@ MODE and ARGS can be one of the following:
 
     module KMOD       generate a KABI file for the specified kernel module
 
-Written by Gordon Matzigkeit <gord\@clusterfs.com> for Cluster File Systems.
+Written by Gordon Matzigkeit <gord\@clusterfs.com> for Sun Microsystems, Inc.
 EOF
     }
     exit $status;
diff --git a/build/linux-rhconfig.h b/build/linux-rhconfig.h
index a7aa42442cafafc4f17daba132e5590e169417b6..bee924eb7b2791856f7f008f55b4638b8216e4a3 100644
--- a/build/linux-rhconfig.h
+++ b/build/linux-rhconfig.h
@@ -1,3 +1,39 @@
+/* -*- mode: c; c-basic-offset: 8; indent-tabs-mode: nil; -*-
+ * vim:expandtab:shiftwidth=8:tabstop=8:
+ *
+ * GPL HEADER START
+ *
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 only,
+ * as published by the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful, but
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+ * General Public License version 2 for more details (a copy is included
+ * in the LICENSE file that accompanied this code).
+ *
+ * You should have received a copy of the GNU General Public License
+ * version 2 along with this program; If not, see [sun.com URL with a
+ * copy of GPLv2].
+ *
+ * Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+ * CA 95054 USA or visit www.sun.com if you need additional information or
+ * have any questions.
+ *
+ * GPL HEADER END
+ */
+/*
+ * Copyright  2008 Sun Microsystems, Inc. All rights reserved
+ * Use is subject to license terms.
+ */
+/*
+ * This file is part of Lustre, http://www.lustre.org/
+ * Lustre is a trademark of Sun Microsystems, Inc.
+ */
+
 /*
  * Try to be a little smarter about which kernel are we currently running
  */
diff --git a/build/lustre-kernel-2.4.spec.in b/build/lustre-kernel-2.4.spec.in
index 41efbb3520370886a7d98518e0981108df306394..2ea23069e2c011ca7823f2d311398d658f0e8d62 100644
--- a/build/lustre-kernel-2.4.spec.in
+++ b/build/lustre-kernel-2.4.spec.in
@@ -171,7 +171,7 @@ BuildPreReq: patch >= 2.5.4, bash >= 2.03, sh-utils, gnupg, tar
 BuildPreReq: bzip2, findutils, dev, gzip, m4
 %endif
 
-Vendor: Cluster File Systems, Inc.
+Vendor: Sun Microsystems, Inc.
 URL: http://www.kernel.org/
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 
@@ -691,7 +691,7 @@ if [ "%{buildbase}" -ne 0 ] ; then
     mkdir -p $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs
     cp ../lustre/kernel_patches/kernel_configs/kernel-%{kversion}-@LUSTRE_TARGET@*.config $RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}/configs
     if [ "%{linux26}" -ne 0 ] ; then
-        # this only works because CFS only builds one kernel per target/arch per kernel-source rpm
+        # this only works because Sun only builds one kernel per target/arch per kernel-source rpm
 	objdir=$RPM_BUILD_ROOT/usr/src/linux-%{KVERREL}-obj
 	mkdir -p $objdir
         if [ "%{buildbigmem}" -ne 0 ] ; then
diff --git a/build/osxpack/License.txt b/build/osxpack/License.txt
index eb250a6c632bdb84ff3de013c6d0b9d281811ae9..3b8ff2b634d31493e5722b22e1e4da99f0298546 100644
--- a/build/osxpack/License.txt
+++ b/build/osxpack/License.txt
@@ -1,8 +1,8 @@
 Lustre(R) for OS X
 
-This software is a proprietary product of Cluster File Systems, Inc. which owns all intellectual property rights to this software.
+This software is a proprietary product of Sun Microsystems, Inc. which owns all intellectual property rights to this software.
 
-You must obtain a license from Cluster File Systems and agree to its terms before using this software.  Contact sales@clusterfs.com
+You must obtain a license from Sun Microsystems, Inc. and agree to its terms before using this software.  Contact http://www.lustre.org/
 
 This software is beta software modifying and running kernel code.  Back up all systems before use.  This software is provided to you without any warranty, without even the implied warranty of merchantability, or fitness for a particular purpose.  Consult your license agreement for more details.
 
diff --git a/build/pkginfo b/build/pkginfo
index 223520b4962a4238475d800e586776ea02928008..96b0e10cce04d260789ebf20f58049d1d6ed7d08 100644
--- a/build/pkginfo
+++ b/build/pkginfo
@@ -1,23 +1,34 @@
+# GPL HEADER START
 #
-#  Copyright (C) 2007 Cluster File Systems, Inc.
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
 #
-#   This file is part of Lustre, http://www.lustre.org.
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
 #
-#   Lustre is free software; you can redistribute it and/or
-#   modify it under the terms of version 2 of the GNU General Public
-#   License as published by the Free Software Foundation.
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
 #
-#   Lustre is distributed in the hope that it will be useful,
-#   but WITHOUT ANY WARRANTY; without even the implied warranty of
-#   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-#   GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see [sun.com URL with a
+# copy of GPLv2].
 #
-#   You should have received a copy of the GNU General Public License
-#   along with Lustre; if not, write to the Free Software
-#   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
 #
-
+# GPL HEADER END
+#
+# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Use is subject to license terms.
 #
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
+
 # Package CFSuoss
 #
 
@@ -31,7 +42,7 @@ SUNW_PKGTYPE="usr"
 MAXINST="1000"
 CATEGORY="system"
 DESC="Lustre Object Storage Server and utilities"
-VENDOR="Cluster Filesystems, Inc."
+VENDOR="Sun Microsystems, Inc."
 HOTLINE="Please contact your local service provider"
 EMAIL=""
 CLASSES="none"
diff --git a/build/prototype b/build/prototype
index 8620e8e16c559a56fee19c0e924998fa7078c637..6b6e7b1675f39ac1c8bce1da90ad2864331dc2a1 100644
--- a/build/prototype
+++ b/build/prototype
@@ -1,20 +1,32 @@
+# GPL HEADER START
 #
-#  Copyright (C) 2007 Cluster File Systems, Inc.
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
 #
-#   This file is part of Lustre, http://www.lustre.org.
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
 #
-#   Lustre is free software; you can redistribute it and/or
-#   modify it under the terms of version 2 of the GNU General Public
-#   License as published by the Free Software Foundation.
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
 #
-#   Lustre is distributed in the hope that it will be useful,
-#   but WITHOUT ANY WARRANTY; without even the implied warranty of
-#   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-#   GNU General Public License for more details.
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see [sun.com URL with a
+# copy of GPLv2].
 #
-#   You should have received a copy of the GNU General Public License
-#   along with Lustre; if not, write to the Free Software
-#   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+# GPL HEADER END
+#
+# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Use is subject to license terms.
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
 #
 
 # Package CFSuoss
@@ -36,4 +48,4 @@ s none usr/bin/lustre_uoss=../../usr/lib/fs/lustre/lustre_uoss
 #s none usr/bin/lustre_echoserver=../../usr/lib/fs/lustre/lustre_echoserver
 f none usr/lib/fs/lustre/readme.txt=../lustre/utils/uoss.readme.txt 444 root bin
 f none usr/lib/libzpool.so.1=$(DMU_SRC)/usr/src/lib/libzpool/i386/libzpool.so.1  755 root bin
-s none usr/lib/libzpool.so=libzpool.so.1
\ No newline at end of file
+s none usr/lib/libzpool.so=libzpool.so.1
diff --git a/ldiskfs/lustre-ldiskfs.spec.in b/ldiskfs/lustre-ldiskfs.spec.in
index 52cb7f3dd0cb53ac4dcef48e4f942939b72afe0f..b76f6d643a613ce8f5733c803d264e4b4fb4ea93 100644
--- a/ldiskfs/lustre-ldiskfs.spec.in
+++ b/ldiskfs/lustre-ldiskfs.spec.in
@@ -8,7 +8,7 @@ Release: @RELEASE@
 License: GPL
 Group: Development/Kernel
 Source: lustre-ldiskfs-%{version}.tar.gz
-URL: http://clusterfs.com/
+URL: http://www.sun.com/software/products/lustre/index.xml
 BuildRoot: %{_tmppath}/lustre-ldiskfs-%{version}-root
 Requires: modutils >= 2.4.10