diff --git a/lnet/archdep.m4 b/lnet/archdep.m4
index 6171555571d89ddbc90206bab5c6047c86747a86..f3f0fb472e501f725dfce8dbf82e48c7ac4a0e2d 100644
--- a/lnet/archdep.m4
+++ b/lnet/archdep.m4
@@ -244,9 +244,9 @@ else
   AC_MSG_RESULT(no)
 fi
 
-AC_ARG_ENABLE(zerocopy, [  --enable-zerocopy enable socknal zerocopy],enable_zerocopy=$enable_zerocopy_temp, enable_zerocopy="")
+AC_ARG_ENABLE(zerocopy, [  --disable-zerocopy disable socknal zerocopy],enable_zerocopy="", enable_zerocopy=$enable_zerocopy_temp)
 
-AC_ARG_ENABLE(affinity, [  --enable-affinity enable process/irq affinity],enable_affinity="-DCPU_AFFINITY=1", enable_affinity=$enable_affinity_temp)
+AC_ARG_ENABLE(affinity, [  --disable-affinity disable process/irq affinity],enable_affinity="", enable_affinity=$enable_affinity_temp)
 #####################################
 
 AC_MSG_CHECKING(if quadrics kernel headers are present)
diff --git a/lustre/ChangeLog b/lustre/ChangeLog
index 351338302e8a109c01312644954fe4bdc564f817..b23303183de71727af80656160cdd058c3001e36 100644
--- a/lustre/ChangeLog
+++ b/lustre/ChangeLog
@@ -6,6 +6,7 @@ tbd         Cluster File Systems, Inc. <info@clusterfs.com>
 	- change default debug level to reasonable production setting
 	- reduce client side cache size to reduce cache flush time
 	- reduce max RPCs in flight to avoid unnecessary file fragmentation
+	- make TCP zerocopy and pinger support enabled by default (2476)
 	- sync writes completed after process exits caused crashes (2319)
 	- maintain correct mount count on the MDS (2356)
 	- backout 1557, because 2316 wasn't really fixed
diff --git a/lustre/configure.in b/lustre/configure.in
index 48e55f7dcd2281c33c11241b34caf3433581184b..c60f8686f9efa2ec8106f7a0dfdddc36905844bb 100644
--- a/lustre/configure.in
+++ b/lustre/configure.in
@@ -28,8 +28,8 @@ AM_CONDITIONAL(DOC, test x$ENABLE_DOC = x1)
 AC_SUBST(ENABLE_DOC)
 
 # the pinger is temporary, until we have the recovery node in place
-AC_ARG_ENABLE(pinger, [  --enable-pinger recovery pinger support])
-if test x$enable_pinger = xyes ; then
+AC_ARG_ENABLE(pinger, [  --disable-pinger disable recovery pinger support])
+if test x$enable_pinger != xno ; then
   AC_DEFINE(ENABLE_PINGER, 1, Use the Pinger)
 fi
 
diff --git a/lustre/portals/archdep.m4 b/lustre/portals/archdep.m4
index 6171555571d89ddbc90206bab5c6047c86747a86..f3f0fb472e501f725dfce8dbf82e48c7ac4a0e2d 100644
--- a/lustre/portals/archdep.m4
+++ b/lustre/portals/archdep.m4
@@ -244,9 +244,9 @@ else
   AC_MSG_RESULT(no)
 fi
 
-AC_ARG_ENABLE(zerocopy, [  --enable-zerocopy enable socknal zerocopy],enable_zerocopy=$enable_zerocopy_temp, enable_zerocopy="")
+AC_ARG_ENABLE(zerocopy, [  --disable-zerocopy disable socknal zerocopy],enable_zerocopy="", enable_zerocopy=$enable_zerocopy_temp)
 
-AC_ARG_ENABLE(affinity, [  --enable-affinity enable process/irq affinity],enable_affinity="-DCPU_AFFINITY=1", enable_affinity=$enable_affinity_temp)
+AC_ARG_ENABLE(affinity, [  --disable-affinity disable process/irq affinity],enable_affinity="", enable_affinity=$enable_affinity_temp)
 #####################################
 
 AC_MSG_CHECKING(if quadrics kernel headers are present)