From d490cf0311f1f68c4e52a7ba4741146cc0068f4d Mon Sep 17 00:00:00 2001
From: adilger <adilger>
Date: Tue, 6 Jan 2004 18:34:09 +0000
Subject: [PATCH] Make TCP zerocopy and pinger support enabled by default
 (affinity already was) b=2476 r=phil

---
 lnet/archdep.m4           | 4 ++--
 lustre/ChangeLog          | 1 +
 lustre/configure.in       | 4 ++--
 lustre/portals/archdep.m4 | 4 ++--
 4 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/lnet/archdep.m4 b/lnet/archdep.m4
index 6171555571..f3f0fb472e 100644
--- a/lnet/archdep.m4
+++ b/lnet/archdep.m4
@@ -244,9 +244,9 @@ else
   AC_MSG_RESULT(no)
 fi
 
-AC_ARG_ENABLE(zerocopy, [  --enable-zerocopy enable socknal zerocopy],enable_zerocopy=$enable_zerocopy_temp, enable_zerocopy="")
+AC_ARG_ENABLE(zerocopy, [  --disable-zerocopy disable socknal zerocopy],enable_zerocopy="", enable_zerocopy=$enable_zerocopy_temp)
 
-AC_ARG_ENABLE(affinity, [  --enable-affinity enable process/irq affinity],enable_affinity="-DCPU_AFFINITY=1", enable_affinity=$enable_affinity_temp)
+AC_ARG_ENABLE(affinity, [  --disable-affinity disable process/irq affinity],enable_affinity="", enable_affinity=$enable_affinity_temp)
 #####################################
 
 AC_MSG_CHECKING(if quadrics kernel headers are present)
diff --git a/lustre/ChangeLog b/lustre/ChangeLog
index 351338302e..b23303183d 100644
--- a/lustre/ChangeLog
+++ b/lustre/ChangeLog
@@ -6,6 +6,7 @@ tbd         Cluster File Systems, Inc. <info@clusterfs.com>
 	- change default debug level to reasonable production setting
 	- reduce client side cache size to reduce cache flush time
 	- reduce max RPCs in flight to avoid unnecessary file fragmentation
+	- make TCP zerocopy and pinger support enabled by default (2476)
 	- sync writes completed after process exits caused crashes (2319)
 	- maintain correct mount count on the MDS (2356)
 	- backout 1557, because 2316 wasn't really fixed
diff --git a/lustre/configure.in b/lustre/configure.in
index 48e55f7dcd..c60f8686f9 100644
--- a/lustre/configure.in
+++ b/lustre/configure.in
@@ -28,8 +28,8 @@ AM_CONDITIONAL(DOC, test x$ENABLE_DOC = x1)
 AC_SUBST(ENABLE_DOC)
 
 # the pinger is temporary, until we have the recovery node in place
-AC_ARG_ENABLE(pinger, [  --enable-pinger recovery pinger support])
-if test x$enable_pinger = xyes ; then
+AC_ARG_ENABLE(pinger, [  --disable-pinger disable recovery pinger support])
+if test x$enable_pinger != xno ; then
   AC_DEFINE(ENABLE_PINGER, 1, Use the Pinger)
 fi
 
diff --git a/lustre/portals/archdep.m4 b/lustre/portals/archdep.m4
index 6171555571..f3f0fb472e 100644
--- a/lustre/portals/archdep.m4
+++ b/lustre/portals/archdep.m4
@@ -244,9 +244,9 @@ else
   AC_MSG_RESULT(no)
 fi
 
-AC_ARG_ENABLE(zerocopy, [  --enable-zerocopy enable socknal zerocopy],enable_zerocopy=$enable_zerocopy_temp, enable_zerocopy="")
+AC_ARG_ENABLE(zerocopy, [  --disable-zerocopy disable socknal zerocopy],enable_zerocopy="", enable_zerocopy=$enable_zerocopy_temp)
 
-AC_ARG_ENABLE(affinity, [  --enable-affinity enable process/irq affinity],enable_affinity="-DCPU_AFFINITY=1", enable_affinity=$enable_affinity_temp)
+AC_ARG_ENABLE(affinity, [  --disable-affinity disable process/irq affinity],enable_affinity="", enable_affinity=$enable_affinity_temp)
 #####################################
 
 AC_MSG_CHECKING(if quadrics kernel headers are present)
-- 
GitLab