From da5f2db0944530f2b30782c019a8d5d20677d02d Mon Sep 17 00:00:00 2001
From: jacob <jacob>
Date: Sat, 5 Feb 2005 00:53:16 +0000
Subject: [PATCH] remove arch symlink

---
 lnet/autoMakefile.am         | 17 +----------------
 lnet/include/libcfs/kp30.h   |  8 +++++++-
 lnet/include/libcfs/libcfs.h | 10 +++++++++-
 3 files changed, 17 insertions(+), 18 deletions(-)

diff --git a/lnet/autoMakefile.am b/lnet/autoMakefile.am
index 50d829873e..b49b8d4198 100644
--- a/lnet/autoMakefile.am
+++ b/lnet/autoMakefile.am
@@ -6,20 +6,5 @@
 SUBDIRS = libcfs portals knals unals router tests doc utils include	\
 	autoconf
 
-sources: include/libcfs/arch
+sources:
 	$(MAKE) sources -C libcfs
-
-all-recursive: include/libcfs/arch
-
-include/libcfs/arch:
-	case `uname` in						  \
-		Linux)						  \
-			ln -s linux include/libcfs/arch		  \
-			;;					  \
-		Darwin)						  \
-			ln -s darwin include/libcfs/arch	  \
-			;;					  \
-		*)						  \
-			echo "Platform `uname` is not supported"  \
-			;;					  \
-	esac
diff --git a/lnet/include/libcfs/kp30.h b/lnet/include/libcfs/kp30.h
index cdd1bffb83..6fd88e752b 100644
--- a/lnet/include/libcfs/kp30.h
+++ b/lnet/include/libcfs/kp30.h
@@ -7,7 +7,13 @@
 #define PORTAL_DEBUG
 #include <libcfs/libcfs.h>
 
-#include <libcfs/arch/kp30.h>
+#if defined(__linux__)
+#include <libcfs/linux/kp30.h>
+#elif defined(__APPLE__)
+#include <libcfs/darwin/kp30.h>
+#else
+#error Unsupported operating system
+#endif
 
 #ifdef __KERNEL__
 
diff --git a/lnet/include/libcfs/libcfs.h b/lnet/include/libcfs/libcfs.h
index 2fabeab4b1..ecc708602f 100644
--- a/lnet/include/libcfs/libcfs.h
+++ b/lnet/include/libcfs/libcfs.h
@@ -8,7 +8,14 @@
 #define __attribute__(x)
 #endif
 
-#include <libcfs/arch/libcfs.h>
+#if defined(__linux__)
+#include <libcfs/linux/libcfs.h>
+#elif defined(__APPLE__)
+#include <libcfs/darwin/libcfs.h>
+#else
+#error Unsupported operating system.
+#endif
+
 #include "curproc.h"
 
 #define PORTAL_DEBUG
@@ -90,6 +97,7 @@ extern unsigned int portal_printk;
 #define D_READA       0x00400000 /* read-ahead */
 #define D_MMAP        0x00800000
 #define D_CONFIG      0x01000000
+#define D_CONSOLE     0x02000000
 /* If you change these values, please keep these files up to date...
  *    portals/utils/debug.c
  *    utils/lconf
-- 
GitLab