From de84b44fbc041e8080556d4528d0af18ad0da569 Mon Sep 17 00:00:00 2001
From: kalpak <kalpak>
Date: Fri, 31 Aug 2007 08:49:19 +0000
Subject: [PATCH] b=10555 i=adilger, girish

Small change in ldiskfs/Makefile.in for new fiemap.h file.

Also fiemap patch chanegs the definition of ext3_prepare_callback, so effect the change in fsfilt_ext3.c.
---
 lustre/lvfs/fsfilt_ext3.c | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/lustre/lvfs/fsfilt_ext3.c b/lustre/lvfs/fsfilt_ext3.c
index 40c8d7b2b1..5197bbf9e1 100644
--- a/lustre/lvfs/fsfilt_ext3.c
+++ b/lustre/lvfs/fsfilt_ext3.c
@@ -971,13 +971,15 @@ static unsigned long new_blocks(handle_t *handle, struct ext3_ext_base *base,
 static int ext3_ext_new_extent_cb(struct ext3_ext_base *base,
                                   struct ext3_ext_path *path,
                                   struct ext3_ext_cache *cex,
+                                  struct ext3_extents *ex,
                                   void *cbdata)
 {
         struct bpointers *bp = cbdata;
 #else
 static int ext3_ext_new_extent_cb(struct ext3_ext_base *base,
                                   struct ext3_ext_path *path,
-                                  struct ext3_ext_cache *cex)
+                                  struct ext3_ext_cache *cex,
+                                  struct ext3_extent *ex)
 {
         struct bpointers *bp = base->private;
 #endif
-- 
GitLab