diff --git a/lustre/scripts/lmake b/lustre/scripts/lmake
index c11496135dad9dac02cd5458cce53085a51fafd6..8a5143e6feb5f9f4bd35c62625ecfc789d30b589 100755
--- a/lustre/scripts/lmake
+++ b/lustre/scripts/lmake
@@ -359,8 +359,8 @@ install_kernel()
 	    mkdir -p "$DESTDIR/boot/efi/redhat"
 	    install -m 755 vmlinux "$DESTDIR/boot/efi/redhat/vmlinux-${FULL_VERSION}"
 	    install -m 755 vmlinuz "$DESTDIR/boot/efi/redhat/vmlinuz-${FULL_VERSION}"
-	    ln -sf "efi/vmlinux-${FULL_VERSION}" "$DESTDIR/boot/vmlinux-${FULL_VERSION}"
-	    ln -sf "efi/vmlinuz-${FULL_VERSION}" "$DESTDIR/boot/vmlinuz-${FULL_VERSION}"
+	    ln -sf "efi/redhat/vmlinux-${FULL_VERSION}" "$DESTDIR/boot/vmlinux-${FULL_VERSION}"
+	    ln -sf "efi/redhat/vmlinuz-${FULL_VERSION}" "$DESTDIR/boot/vmlinuz-${FULL_VERSION}"
 	    ;;
 	*)
 	    cp vmlinuz "$DESTDIR/boot/vmlinuz-${FULL_VERSION}"
diff --git a/lustre/scripts/lustre-kernel-2.4.spec.in b/lustre/scripts/lustre-kernel-2.4.spec.in
index 0999212edf4d4de7edf60f27605da82d7274f2bd..3fef13d95666bfd2e55338200b972ec2522d32d6 100644
--- a/lustre/scripts/lustre-kernel-2.4.spec.in
+++ b/lustre/scripts/lustre-kernel-2.4.spec.in
@@ -129,7 +129,7 @@ Release: %{release}%{?targetboard:%{targetboard}}%{?debuglevel_1:.dbg}
 %define KVERREL %{PACKAGE_VERSION}-%{kextraver}%{?targetboard:%{targetboard}}%{?debuglevel_1:.dbg}
 License: GPL
 Group: System Environment/Kernel
-ExclusiveArch: %{all_x86} x86_64
+ExclusiveArch: %{all_x86} x86_64 ia64
 ExclusiveOS: Linux
 Obsoletes: kernel-modules, kernel-sparc
 Provides: kernel = %{version}