Commit e5c77ea2 authored by Kubo Takehiro's avatar Kubo Takehiro
Browse files

ruby-oci8.rb was added for 'Bundler.require'.

github issue #114
parent 68d2d513
2016-03-27 Kubo Takehiro <kubo@jiubao.org>
* lib/ruby-oci8.rb: Added for 'Bundler.require'.
(github issue #114)
* dist-files: Add lib/ruby-oci8.rb.
2016-03-27 Kubo Takehiro <kubo@jiubao.org>
* README.md, docs/timeout-parameters.md, lib/oci8/oci8.rb:
Update documents about timeout parameters.
......
......@@ -75,6 +75,7 @@ lib/oci8/ocihandle.rb
lib/oci8/oracle_version.rb
lib/oci8/properties.rb
lib/oci8/version.rb
lib/ruby-oci8.rb
test/README
test/config.rb
test/setup_test_object.sql
......
if caller[0] !~ /\/bundler\/runtime\.rb:\d+:in `require'/
warn "Don't requie 'ruby-oci8'. Use \"require 'oci8'\" instead. 'ruby-oci8.rb' was added only for 'Bundler.require'."
end
require 'oci8'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment