diff --git a/META b/META
index 2b3414b895b44c6e518282b6a941880ef9f74ea7..42af05136bde9c0998f3310aaec5927eff5e111b 100644
--- a/META
+++ b/META
@@ -11,7 +11,7 @@
   Minor:	03
   Micro:	1
   Version:	14.03.1
-  Release:	1
+  Release:	2
 
 ##
 #  When changing API_CURRENT update src/common/slurm_protocol_common.h
diff --git a/NEWS b/NEWS
index 8af5cb58f532d36e69437e062f4ae17757ca4745..07324e530ca0271c6ab506e259900b96fb2a74a9 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,13 @@
 This file describes changes in recent versions of Slurm. It primarily
 documents those changes that are of interest to users and admins.
 
+* Changes in Slurm 14.03.2
+==========================
+
+* Changes in Slurm 14.03.1-2
+==========================
+ -- Update configure to set correct version without having to run autogen.sh
+
 * Changes in Slurm 14.03.1
 ==========================
  -- Add support for job std_in, std_out and std_err fields in Perl API.
diff --git a/auxdir/slurm.m4 b/auxdir/slurm.m4
index a519e642e5286d208d186060732b7ea9b0b637df..b43f71d5a2f410f7e78b21457a06910337a23625 100644
--- a/auxdir/slurm.m4
+++ b/auxdir/slurm.m4
@@ -233,6 +233,7 @@ AC_DEFINE_UNQUOTED(SLURM_MICRO, "$SLURM_MICRO",
 AC_DEFINE_UNQUOTED(RELEASE, "$RELEASE", [Define the project's release.])
 AC_DEFINE_UNQUOTED(SLURM_VERSION_STRING, "$SLURM_VERSION_STRING",
                    [Define the project's version string.])
+
 AC_SUBST(SLURM_MAJOR)
 AC_SUBST(SLURM_MINOR)
 AC_SUBST(SLURM_MICRO)
diff --git a/configure b/configure
index 6289682e7c5aca91e8e6e304bffd9eaaa997d7c9..e57fe49b13970f58c1aa30ef2429a65544fa897b 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
 #! /bin/sh
 # Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for slurm 14.03.0.
+# Generated by GNU Autoconf 2.69 for slurm 14.03.
 #
 # Report bugs to <slurm-dev@schedmd.com>.
 #
@@ -590,8 +590,8 @@ MAKEFLAGS=
 # Identity of this package.
 PACKAGE_NAME='slurm'
 PACKAGE_TARNAME='slurm'
-PACKAGE_VERSION='14.03.0'
-PACKAGE_STRING='slurm 14.03.0'
+PACKAGE_VERSION='14.03'
+PACKAGE_STRING='slurm 14.03'
 PACKAGE_BUGREPORT='slurm-dev@schedmd.com'
 PACKAGE_URL='http://slurm.schedmd.com'
 
@@ -1576,7 +1576,7 @@ if test "$ac_init_help" = "long"; then
   # Omit some internal or obsolete options to make the list less imposing.
   # This message is too long to be a string in the A/UX 3.1 sh.
   cat <<_ACEOF
-\`configure' configures slurm 14.03.0 to adapt to many kinds of systems.
+\`configure' configures slurm 14.03 to adapt to many kinds of systems.
 
 Usage: $0 [OPTION]... [VAR=VALUE]...
 
@@ -1647,7 +1647,7 @@ fi
 
 if test -n "$ac_init_help"; then
   case $ac_init_help in
-     short | recursive ) echo "Configuration of slurm 14.03.0:";;
+     short | recursive ) echo "Configuration of slurm 14.03:";;
    esac
   cat <<\_ACEOF
 
@@ -1835,7 +1835,7 @@ fi
 test -n "$ac_init_help" && exit $ac_status
 if $ac_init_version; then
   cat <<\_ACEOF
-slurm configure 14.03.0
+slurm configure 14.03
 generated by GNU Autoconf 2.69
 
 Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2371,7 +2371,7 @@ cat >config.log <<_ACEOF
 This file contains any messages produced by compilers while
 running configure, to aid debugging if configure makes a mistake.
 
-It was created by slurm $as_me 14.03.0, which was
+It was created by slurm $as_me 14.03, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   $ $0 $@
@@ -3008,6 +3008,7 @@ _ACEOF
 
 
 
+
 am__api_version='1.13'
 
 # Find a good install program.  We prefer a C program (faster),
@@ -3494,7 +3495,7 @@ fi
 
 # Define the identity of the package.
  PACKAGE='slurm'
- VERSION='14.03.0'
+ VERSION='14.03'
 
 
 # Some tools Automake needs.
@@ -24271,7 +24272,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
 # report actual input values of CONFIG_FILES etc. instead of their
 # values after options handling.
 ac_log="
-This file was extended by slurm $as_me 14.03.0, which was
+This file was extended by slurm $as_me 14.03, which was
 generated by GNU Autoconf 2.69.  Invocation command line was
 
   CONFIG_FILES    = $CONFIG_FILES
@@ -24338,7 +24339,7 @@ _ACEOF
 cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
 ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
 ac_cs_version="\\
-slurm config.status 14.03.0
+slurm config.status 14.03
 configured by $0, generated by GNU Autoconf 2.69,
   with options \\"\$ac_cs_config\\"
 
diff --git a/configure.ac b/configure.ac
index 3a8d63e205afa23396c75aefccfa882cb92a2326..1f93c75eebe63a2ff1b26d8a6344b265cd81fbb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@
 dnl Prologue
 dnl
 
-AC_INIT(slurm, m4_esyscmd([perl -ne 'print,exit if s/^\s*VERSION:\s*(\S*).*/\1/i' ./META | sed 's/^v//' | tr '-' '_' | tr -d '\n']), [slurm-dev@schedmd.com], [], [http://slurm.schedmd.com])
+AC_INIT(slurm, m4_esyscmd([perl -ne 'print,exit if s/^\s*VERSION:\s*(\d*.\d*).\S*/\1/i' ./META | sed 's/^v//' | tr '-' '_' | tr -d '\n']), [slurm-dev@schedmd.com], [], [http://slurm.schedmd.com])
 AC_PREREQ(2.59)
 AC_CONFIG_SRCDIR([configure.ac])
 AC_CONFIG_AUX_DIR([auxdir])
diff --git a/doc/html/Makefile.am b/doc/html/Makefile.am
index 0ce91de916ed70efe4d2b7e0eec7d1fd741829d2..bbd219ff71a0b9c9387407258976aa33ff46252f 100644
--- a/doc/html/Makefile.am
+++ b/doc/html/Makefile.am
@@ -1,5 +1,5 @@
 
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 
 generated_html = \
 	accounting.html \
diff --git a/doc/html/Makefile.in b/doc/html/Makefile.in
index 36a7b1872c6ffa77af034d693d70bc461b275406..629c571a9999889b6cbbb2ea443084fa9eeb45bf 100644
--- a/doc/html/Makefile.in
+++ b/doc/html/Makefile.in
@@ -387,7 +387,7 @@ host_alias = @host_alias@
 host_cpu = @host_cpu@
 host_os = @host_os@
 host_vendor = @host_vendor@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 includedir = @includedir@
 infodir = @infodir@
 install_sh = @install_sh@
diff --git a/doc/html/cons_res.shtml b/doc/html/cons_res.shtml
index bae95047def8e7904fce92f7456838d4bb4f8679..1002291c20e6c989ff34aeb4484af686a28ad2f8 100644
--- a/doc/html/cons_res.shtml
+++ b/doc/html/cons_res.shtml
@@ -66,6 +66,7 @@ SelectTypeParameter in the slurm.conf.</li>
 <pre>
 #
 # Excerpts from sample slurm.conf file
+#
 
 SelectType=select/cons_res
 SelectTypeParameters=CR_Core_Memory
@@ -117,9 +118,9 @@ hydra[12-16]     5 allNodes*  ...       4  2:2:1   2007
 <p>Using select/cons_res plug-in with CR_Memory</p>
 <pre>
 Example:
-# srun -N 5 -n 20 --job-mem=1000 sleep 100 &  <-- running
-# srun -N 5 -n 20 --job-mem=10 sleep 100 &    <-- running
-# srun -N 5 -n 10 --job-mem=1000 sleep 100 &  <-- queued and waiting for resources
+# srun -N 5 -n 20 --mem=1000 sleep 100 &  <-- running
+# srun -N 5 -n 20 --mem=10 sleep 100 &    <-- running
+# srun -N 5 -n 10 --mem=1000 sleep 100 &  <-- queued and waiting for resources
 
 # squeue
 JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
@@ -131,8 +132,8 @@ JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
 <p>Using select/cons_res plug-in with CR_Socket_Memory (2 sockets/node)</p>
 <pre>
 Example 1:
-# srun -N 5 -n 5 --job-mem=1000 sleep 100 &        <-- running
-# srun -n 1 -w hydra12 --job-mem=2000 sleep 100 &  <-- queued and waiting for resources
+# srun -N 5 -n 5 --mem=1000 sleep 100 &        <-- running
+# srun -n 1 -w hydra12 --mem=2000 sleep 100 &  <-- queued and waiting for resources
 
 # squeue
 JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
@@ -140,8 +141,8 @@ JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
  1889  allNodes  sleep sballe  R  0:08      5 hydra[12-16]
 
 Example 2:
-# srun -N 5 -n 10 --job-mem=10 sleep 100 & <-- running
-# srun -n 1 --job-mem=10 sleep 100 & <-- queued and waiting for resourcessqueue
+# srun -N 5 -n 10 --mem=10 sleep 100 & <-- running
+# srun -n 1 --mem=10 sleep 100 & <-- queued and waiting for resourcessqueue
 
 # squeue
 JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
@@ -152,9 +153,9 @@ JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
 <p>Using select/cons_res plug-in with CR_CPU_Memory (4 CPUs/node)</p>
 <pre>
 Example 1:
-# srun -N 5 -n 5 --job-mem=1000 sleep 100 &  <-- running
-# srun -N 5 -n 5 --job-mem=10 sleep 100 &    <-- running
-# srun -N 5 -n 5 --job-mem=1000 sleep 100 &  <-- queued and waiting for resources
+# srun -N 5 -n 5 --mem=1000 sleep 100 &  <-- running
+# srun -N 5 -n 5 --mem=10 sleep 100 &    <-- running
+# srun -N 5 -n 5 --mem=1000 sleep 100 &  <-- queued and waiting for resources
 
 # squeue
 JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
@@ -163,8 +164,8 @@ JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
  1834  allNodes  sleep sballe  R  0:07      5 hydra[12-16]
 
 Example 2:
-# srun -N 5 -n 20 --job-mem=10 sleep 100 & <-- running
-# srun -n 1 --job-mem=10 sleep 100 &       <-- queued and waiting for resources
+# srun -N 5 -n 20 --mem=10 sleep 100 & <-- running
+# srun -n 1 --mem=10 sleep 100 &       <-- queued and waiting for resources
 
 # squeue
 JOBID PARTITION   NAME   USER ST  TIME  NODES NODELIST(REASON)
@@ -340,6 +341,6 @@ one mpi process per node.</p>
 
 <p class="footer"><a href="#top">top</a></p>
 
-<p style="text-align:center;">Last modified 17 January 2014</p>
+<p style="text-align:center;">Last modified 21 April 2014</p>
 
 <!--#include virtual="footer.txt"-->
diff --git a/doc/html/mc_support.shtml b/doc/html/mc_support.shtml
index 93d5f46c8659bfc02dc1fe0e8a344e327ff102e1..748a0298ef4859ba250a201c5fadf9d38ffd235f 100644
--- a/doc/html/mc_support.shtml
+++ b/doc/html/mc_support.shtml
@@ -43,8 +43,8 @@ allowing a process to run on more than one logical processor.
 <a name=flags>
 <h2>Overview of new srun flags</h2></a>
 
-<p> Several new flags have been defined to allow users to
-better take advantage of the new architecture by
+<p> Several flags have been defined to allow users to
+better take advantage of this architecture by
 explicitly specifying the number of sockets, cores, and threads required
 by their application.  Table 1 summarizes the new multi-core flags.
 
@@ -89,8 +89,12 @@ by their application.  Table 1 summarizes the new multi-core flags.
 <b><a href="#srun_consres">Memory as a consumable resource</a></b>
 </td></tr>
 <tr>
-    <td> --job-mem=<i>mem</i></td>
-    <td> maximum amount of real memory per node required by the job.
+    <td> --mem=<i>mem</i></td>
+    <td> amount of real memory per node required by the job.
+</td></tr>
+<tr>
+    <td> --mem-per-cpu=<i>mem</i></td>
+    <td> amount of real memory per allocated CPU required by the job.
 </td></tr>
 <tr><td colspan=2>
 <b><a href="#srun_ntasks">Task invocation control</a></b>
@@ -125,17 +129,13 @@ by their application.  Table 1 summarizes the new multi-core flags.
 Table 1: New srun flags to support the multi-core/multi-threaded environment
 </center>
 
-<p>It is important to note that many of these
-flags are only meaningful if the processes' affinity is set. In order for
-the affinity to be set, the task/affinity plugin must be first enabled in
-slurm.conf:
-
-<PRE>
-TaskPlugin=task/affinity          # enable task affinity
-</PRE>
-
-<p>See the "Task Launch" section if generating slurm.conf via
-<a href="configurator.html">configurator.html</a>.
+<p>It is important to note that many of these flags are only meaningful if the
+processes' have some affinity to specific CPUs and (optionally) memory.
+Task affinity is configured using the TaskPlugin parameter in the slurm.conf file.
+Several options exist for the TaskPlugin depending upon system architecture
+and available software, any of them except "task/none" will find tasks to CPUs.
+See the "Task Launch" section if generating slurm.conf via
+<a href="configurator.html">configurator.html</a>.</p>
 
 <a name="srun_lowlevelmc">
 <h3>Low-level --cpu_bind=... - Explicit binding interface</h3></a>
@@ -150,9 +150,11 @@ TaskPlugin=task/affinity          # enable task affinity
     no[ne]          don't bind tasks to CPUs (default)
     rank            bind by task rank
     map_cpu:<i>&lt;list&gt;</i>  specify a CPU ID binding for each task
-                    where <i>&lt;list&gt;</i> is <i>&lt;cpuid1&gt;,&lt;cpuid2&gt;,...&lt;cpuidN&gt;</i>
-    mask_cpu:<i>&lt;list&gt;</i> specify a CPU ID binding mask for each task
-                    where <i>&lt;list&gt;</i> is <i>&lt;mask1&gt;,&lt;mask2&gt;,...&lt;maskN&gt;</i>
+                    where <i>&lt;list&gt;</i> is
+                    <i>&lt;cpuid1&gt;,&lt;cpuid2&gt;,...&lt;cpuidN&gt;</i>
+    mask_cpu:<i>&lt;list&gt;</i> specify a CPU ID binding mask for each
+                    task where <i>&lt;list&gt;</i> is
+                    <i>&lt;mask1&gt;,&lt;mask2&gt;,...&lt;maskN&gt;</i>
     sockets         auto-generated masks bind to sockets
     cores           auto-generated masks bind to cores
     threads         auto-generated masks bind to threads
@@ -274,18 +276,17 @@ to -m block:cyclic with --cpu_bind=thread.</p>
 <a name="srun_consres">
 <h3>Memory as a Consumable Resource</h3></a>
 
-<p>The --job-mem flag specifies the maximum amount of memory in MB
+<p>The --mem flag specifies the maximum amount of memory in MB
 needed by the job per node.  This flag is used to support the memory
 as a consumable resource allocation strategy.</p>
 
 <PRE>
---job-mem=<i>MB</i>      maximum amount of real memory per node
-                  required by the job.
-                  --mem >= --job-mem if --mem is specified.
+--mem=<i>MB</i>      maximum amount of real memory per node
+              required by the job.
 </PRE>
 
 <p>This flag allows the scheduler to co-allocate jobs on specific nodes
-given that their added memory requirement do not exceed the amount
+given that their added memory requirement do not exceed the total amount
 of memory on the nodes.</p>
 
 
@@ -296,7 +297,7 @@ SelectType=select/cons_res      # enable consumable resources
 SelectTypeParameters=CR_Memory  # memory as a consumable resource
 </PRE>
 
-<p> Using memory as a consumable resource can also be combined with
+<p> Using memory as a consumable resource is typically combined with
 the CPU, Socket, or Core consumable resources using SelectTypeParameters
 values of: CR_CPU_Memory, CR_Socket_Memory or CR_Core_Memory
 
@@ -727,7 +728,7 @@ parts*    4    2:2:1    2        2        1
 the following identifiers are available:</p>
 
 <PRE>
-%m  Minimum size of memory (in MB) requested by the job
+%m  Size of memory (in MB) requested by the job
 %H  Number of requested sockets per node
 %I  Number of requested cores per socket
 %J  Number of requested threads per core
@@ -755,45 +756,16 @@ JOBID ST TIME NODES SOCKETS CORES THREADS S:C:T NODELIST(REASON)
    16  R 1:26     1 2       2     1       2:2:1 hydra15
 </PRE>
 
-<p>
-The display of the minimum size of memory requested by the job has
-been extended to also show the amount of memory requested by
-the --job-mem flag.  If --job-mem and --mem are set to the
-same value, a single number is display for MIN_MEMORY.  Otherwise
-a range is reported:
-
-<p>submit job 21:
-<pre>
-% srun sleep 100 &
-</pre>
+<p>The squeue command can also display the memory size of jobs, for example:</p>
 
-<p>submit job 22:
-<pre>
-% srun --job-mem=2048MB --mem=1024MB sleep 100 &
-srun: mem < job-mem - resizing mem to be equal to job-mem
-</pre>
-
-<p>submit job 23:
-<pre>
-% srun --job-mem=2048MB --mem=10240MB sleep 100 &
-</pre>
+<PRE>
+% sbatch --mem=123 tmp
+Submitted batch job 24
 
-<pre>
-% squeue -o "%.5i %.2t %.4M %.5D %m"
+$ squeue -o "%.5i %.2t %.4M %.5D %m"
 JOBID ST TIME NODES MIN_MEMORY
-   21 PD 0:00     1 0-1
-   22 PD 0:00     1 2048
-   23 PD 0:00     1 2048-10240
-   17  R 1:12     1 0
-   18  R 1:11     1 0
-   19  R 1:11     1 0
-   20  R 1:10     1 0
-</pre>
-
-<p>In the above examples, note that once a job starts running, the
-MIN_* constraints are all reported as zero regardless of what
-their initial values were (since they are meaningless once
-the job starts running).
+  24   R 0:05     1 123
+</PRE>
 
 <p>See also 'squeue --help' and 'man squeue'</p>
 
@@ -977,7 +949,7 @@ using NodeName:
 </PRE>
 
 <!-------------------------------------------------------------------------->
-<p style="text-align:center;">Last modified 22 July 2010</p>
+<p style="text-align:center;">Last modified 21 April 2014</p>
 
 <!--#include virtual="footer.txt"-->
 
diff --git a/doc/html/slurm_ug_cfp.shtml b/doc/html/slurm_ug_cfp.shtml
index 96086fa9fe415bda44e758fd502c9c88f367d772..3ea0dcac1acedfa9506ccb4a4fbb7d5984912d9e 100644
--- a/doc/html/slurm_ug_cfp.shtml
+++ b/doc/html/slurm_ug_cfp.shtml
@@ -16,7 +16,7 @@ will be held in Lugano, Switzerland on 23-24 September 2014.</p>
 <li>Learn more about <a href="http://slurm.schedmd.com/">
 Slurm</a>, a highly scalable Resource Manager and Job Scheduler</li>
 <li>Share their knowledge and experience with other users and administrators</li>
-<li>Get detailed informations about the latest features and developments</li>
+<li>Get detailed information about the latest features and developments</li>
 <li>Share requirements and discuss future developments</li>
 </ul></p>
 
diff --git a/doc/man/man1/Makefile.am b/doc/man/man1/Makefile.am
index 57be1510f635fb93768274c8bee62f1dedf2e3a6..740f695fef9d2f06bbceafabc634f27c53e5c04c 100644
--- a/doc/man/man1/Makefile.am
+++ b/doc/man/man1/Makefile.am
@@ -1,4 +1,4 @@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 
 man1_MANS = \
 	sacct.1 \
diff --git a/doc/man/man1/Makefile.in b/doc/man/man1/Makefile.in
index bf78af469b3e659fd4c2c459df8335fb15252bbb..1958f6435d10153c7d6b2d219f72bd36c2690848 100644
--- a/doc/man/man1/Makefile.in
+++ b/doc/man/man1/Makefile.in
@@ -389,7 +389,7 @@ host_alias = @host_alias@
 host_cpu = @host_cpu@
 host_os = @host_os@
 host_vendor = @host_vendor@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 includedir = @includedir@
 infodir = @infodir@
 install_sh = @install_sh@
diff --git a/doc/man/man5/Makefile.am b/doc/man/man5/Makefile.am
index 20ee3b9ae70035d6f70cd2442653ba06cf4705d0..414875b6527e19741e628551de310965a738f61c 100644
--- a/doc/man/man5/Makefile.am
+++ b/doc/man/man5/Makefile.am
@@ -1,4 +1,4 @@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 
 man5_MANS = \
 	acct_gather.conf.5 \
diff --git a/doc/man/man5/Makefile.in b/doc/man/man5/Makefile.in
index d2fc22b40a45c6f893317bb3f8e5f1ffbbf7c6e9..5ba05eee5f6bab5de5bde65290437aa70f243a27 100644
--- a/doc/man/man5/Makefile.in
+++ b/doc/man/man5/Makefile.in
@@ -389,7 +389,7 @@ host_alias = @host_alias@
 host_cpu = @host_cpu@
 host_os = @host_os@
 host_vendor = @host_vendor@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 includedir = @includedir@
 infodir = @infodir@
 install_sh = @install_sh@
diff --git a/doc/man/man8/Makefile.am b/doc/man/man8/Makefile.am
index 294d9de4610972ff418503db37358e2f69f8149e..6945678167ebb25610b80cbeb57a4e4e404f28e1 100644
--- a/doc/man/man8/Makefile.am
+++ b/doc/man/man8/Makefile.am
@@ -1,4 +1,4 @@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 
 man8_MANS = slurmctld.8 \
 	slurmd.8 \
diff --git a/doc/man/man8/Makefile.in b/doc/man/man8/Makefile.in
index b81a1070a59048e343e82601a130082b7b01a3b0..5d00b2f744129093cc2397e756bb74f17db2f260 100644
--- a/doc/man/man8/Makefile.in
+++ b/doc/man/man8/Makefile.in
@@ -389,7 +389,7 @@ host_alias = @host_alias@
 host_cpu = @host_cpu@
 host_os = @host_os@
 host_vendor = @host_vendor@
-htmldir = ${datadir}/doc/@PACKAGE@-@VERSION@/html
+htmldir = ${datadir}/doc/${PACKAGE}-${SLURM_VERSION_STRING}/html
 includedir = @includedir@
 infodir = @infodir@
 install_sh = @install_sh@
diff --git a/src/common/proc_args.c b/src/common/proc_args.c
index f040cf9d550c9593a214765605cd4edb3534faf1..58397281c07f36e09b6d46cd5f76f249e758bc4f 100644
--- a/src/common/proc_args.c
+++ b/src/common/proc_args.c
@@ -85,7 +85,7 @@
 /* print this version of SLURM */
 void print_slurm_version(void)
 {
-	printf("%s\n", PACKAGE_STRING);
+	printf("%s %s\n", PACKAGE_NAME, SLURM_VERSION_STRING);
 }
 
 /* print the available gres options */