Skip to content
Snippets Groups Projects
Commit 08dc0b26 authored by Johann Lombardi's avatar Johann Lombardi
Browse files

Branch b1_8_gate

b=16362
i=bzzz
i=adilger

looking up an inode via iopen with the wrong generation number can
populate the dcache with a disconneced dentry while the inode
number is in the process of being reallocated. This causes an
assertion failure in iopen since the inode's dentry list contains
both a connected and disconnected dentry.
parent d86a763e
No related merge requests found
Index: linux-stage/fs/ext3/Makefile
Index: linux-2.6.5-7.311/fs/ext3/Makefile
===================================================================
--- linux-stage.orig/fs/ext3/Makefile 2005-02-25 14:31:53.151076368 +0200
+++ linux-stage/fs/ext3/Makefile 2005-02-25 14:41:51.259150120 +0200
--- linux-2.6.5-7.311.orig/fs/ext3/Makefile
+++ linux-2.6.5-7.311/fs/ext3/Makefile
@@ -4,7 +4,7 @@
obj-$(CONFIG_EXT3_FS) += ext3.o
......@@ -11,10 +11,10 @@ Index: linux-stage/fs/ext3/Makefile
ioctl.o namei.o super.o symlink.o hash.o
ext3-$(CONFIG_EXT3_FS_XATTR) += xattr.o xattr_user.o xattr_trusted.o
Index: linux-stage/fs/ext3/inode.c
Index: linux-2.6.5-7.311/fs/ext3/inode.c
===================================================================
--- linux-stage.orig/fs/ext3/inode.c 2005-02-25 14:37:30.983718000 +0200
+++ linux-stage/fs/ext3/inode.c 2005-02-25 14:47:42.069818792 +0200
--- linux-2.6.5-7.311.orig/fs/ext3/inode.c
+++ linux-2.6.5-7.311/fs/ext3/inode.c
@@ -37,6 +37,7 @@
#include <linux/mpage.h>
#include <linux/uio.h>
......@@ -23,7 +23,7 @@ Index: linux-stage/fs/ext3/inode.c
#include "acl.h"
/*
@@ -2408,6 +2409,9 @@
@@ -2419,6 +2420,9 @@ void ext3_read_inode(struct inode * inod
#endif
ei->i_rsv_window.rsv_end = EXT3_RESERVE_WINDOW_NOT_ALLOCATED;
......@@ -33,11 +33,11 @@ Index: linux-stage/fs/ext3/inode.c
if (ext3_get_inode_loc(inode, &iloc, 0))
goto bad_inode;
bh = iloc.bh;
Index: linux-stage/fs/ext3/iopen.c
Index: linux-2.6.5-7.311/fs/ext3/iopen.c
===================================================================
--- linux-2.6.5-sles9.orig/fs/ext3/iopen.c 2003-01-30 13:24:37.000000000 +0300
+++ linux-2.6.5-sles9/fs/ext3/iopen.c 2004-11-09 02:18:27.611913312 +0300
@@ -0,0 +1,278 @@
--- /dev/null
+++ linux-2.6.5-7.311/fs/ext3/iopen.c
@@ -0,0 +1,314 @@
+/*
+ * linux/fs/ext3/iopen.c
+ *
......@@ -238,6 +238,42 @@ Index: linux-stage/fs/ext3/iopen.c
+}
+
+/*
+ * Similar as d_instantiate() except that it drops the disconnected
+ * dentry if any.
+ */
+void iopen_d_instantiate(struct dentry *dentry, struct inode * inode)
+{
+ struct dentry *dis_dentry;
+
+ /* verify this dentry is really new */
+ assert(dentry->d_inode == NULL);
+ assert(list_empty(&dentry->d_alias));
+
+ spin_lock(&dcache_lock);
+ if (!inode || !test_opt(inode->i_sb, IOPEN) ||
+ list_empty(&inode->i_dentry))
+ goto do_instantiate;
+
+ /* a disconnected dentry has been added in our back,
+ * we have to drop this dentry, see bug 16362/15713*/
+ dis_dentry = list_entry(inode->i_dentry.next, struct dentry, d_alias);
+ spin_lock(&dis_dentry->d_lock);
+ assert(dis_dentry->d_alias.next == &inode->i_dentry);
+ assert(dis_dentry->d_alias.prev == &inode->i_dentry);
+ assert(dis_dentry->d_flags & DCACHE_DISCONNECTED);
+ __d_drop(dis_dentry);
+ list_del_init(&dis_dentry->d_alias);
+ spin_unlock(&dis_dentry->d_lock);
+
+do_instantiate:
+ if (inode)
+ list_add(&dentry->d_alias, &inode->i_dentry);
+ dentry->d_inode = inode;
+ spin_unlock(&dcache_lock);
+ security_d_instantiate(dentry, inode);
+}
+
+/*
+ * These are the special structures for the iopen pseudo directory.
+ */
+
......@@ -316,11 +352,11 @@ Index: linux-stage/fs/ext3/iopen.c
+
+ return 1;
+}
Index: linux-stage/fs/ext3/iopen.h
Index: linux-2.6.5-7.311/fs/ext3/iopen.h
===================================================================
--- linux-stage.orig/fs/ext3/iopen.h 2005-02-25 14:41:01.017787968 +0200
+++ linux-stage/fs/ext3/iopen.h 2005-02-25 14:41:01.045783712 +0200
@@ -0,0 +1,23 @@
--- /dev/null
+++ linux-2.6.5-7.311/fs/ext3/iopen.h
@@ -0,0 +1,24 @@
+/*
+ * iopen.h
+ *
......@@ -336,6 +372,7 @@ Index: linux-stage/fs/ext3/iopen.h
+extern int ext3_iopen_get_inode(struct inode *inode);
+extern struct dentry *iopen_connect_dentry(struct dentry *dentry,
+ struct inode *inode, int rehash);
+extern void iopen_d_instantiate(struct dentry *dentry, struct inode * inode);
+
+#if !defined(HAVE_D_REHASH_COND) && defined(HAVE___D_REHASH)
+#define d_rehash_cond(dentry, lock) __d_rehash(dentry, lock)
......@@ -344,10 +381,10 @@ Index: linux-stage/fs/ext3/iopen.h
+#if !defined(HAVE_D_MOVE_LOCKED) && defined(HAVE___D_MOVE)
+#define d_move_locked(dentry, target) __d_move(dentry, target)
+#endif
Index: linux-stage/fs/ext3/namei.c
Index: linux-2.6.5-7.311/fs/ext3/namei.c
===================================================================
--- linux-stage.orig/fs/ext3/namei.c 2005-02-25 14:37:28.975023368 +0200
+++ linux-stage/fs/ext3/namei.c 2005-02-25 14:46:43.090784968 +0200
--- linux-2.6.5-7.311.orig/fs/ext3/namei.c
+++ linux-2.6.5-7.311/fs/ext3/namei.c
@@ -37,6 +37,7 @@
#include <linux/buffer_head.h>
#include <linux/smp_lock.h>
......@@ -356,7 +393,7 @@ Index: linux-stage/fs/ext3/namei.c
#include "acl.h"
/*
@@ -980,6 +981,9 @@
@@ -1024,6 +1025,9 @@ static struct dentry *ext3_lookup(struct
if (dentry->d_name.len > EXT3_NAME_LEN)
return ERR_PTR(-ENAMETOOLONG);
......@@ -366,7 +403,7 @@ Index: linux-stage/fs/ext3/namei.c
bh = ext3_find_entry(dentry, &de);
inode = NULL;
if (bh) {
@@ -990,10 +994,8 @@
@@ -1034,10 +1038,8 @@ static struct dentry *ext3_lookup(struct
if (!inode)
return ERR_PTR(-EACCES);
}
......@@ -379,7 +416,25 @@ Index: linux-stage/fs/ext3/namei.c
}
@@ -2037,10 +2039,6 @@
@@ -1653,7 +1655,7 @@ static int ext3_add_nondir(handle_t *han
if (!err) {
err = ext3_mark_inode_dirty(handle, inode);
if (!err) {
- d_instantiate(dentry, inode);
+ iopen_d_instantiate(dentry, inode);
return 0;
}
}
@@ -1814,7 +1816,7 @@ retry:
dir->i_nlink++;
ext3_update_dx_flag(dir);
ext3_mark_inode_dirty(handle, dir);
- d_instantiate(dentry, inode);
+ iopen_d_instantiate(dentry, inode);
out_stop:
ext3_journal_stop(handle);
if (err == -ENOSPC && ext3_should_retry_alloc(dir->i_sb, &retries))
@@ -2075,10 +2077,6 @@ static int ext3_rmdir (struct inode * di
inode->i_nlink);
inode->i_version++;
inode->i_nlink = 0;
......@@ -390,7 +445,7 @@ Index: linux-stage/fs/ext3/namei.c
ext3_orphan_add(handle, inode);
inode->i_ctime = dir->i_ctime = dir->i_mtime = CURRENT_TIME;
ext3_mark_inode_dirty(handle, inode);
@@ -2163,6 +2161,23 @@
@@ -2199,6 +2197,23 @@ out_stop:
return err;
}
......@@ -414,7 +469,7 @@ Index: linux-stage/fs/ext3/namei.c
static int ext3_link (struct dentry * old_dentry,
struct inode * dir, struct dentry *dentry)
{
@@ -2186,7 +2201,8 @@
@@ -2222,7 +2237,8 @@ retry:
ext3_inc_count(handle, inode);
atomic_inc(&inode->i_count);
......@@ -424,11 +479,11 @@ Index: linux-stage/fs/ext3/namei.c
ext3_journal_stop(handle);
if (err == -ENOSPC && ext3_should_retry_alloc(dir->i_sb, &retries))
goto retry;
Index: linux-stage/fs/ext3/super.c
Index: linux-2.6.5-7.311/fs/ext3/super.c
===================================================================
--- linux-stage.orig/fs/ext3/super.c 2005-02-25 14:37:30.987717392 +0200
+++ linux-stage/fs/ext3/super.c 2005-02-25 14:44:50.495901992 +0200
@@ -586,6 +586,7 @@
--- linux-2.6.5-7.311.orig/fs/ext3/super.c
+++ linux-2.6.5-7.311/fs/ext3/super.c
@@ -581,6 +581,7 @@ enum {
Opt_abort, Opt_data_journal, Opt_data_ordered, Opt_data_writeback,
Opt_ignore, Opt_barrier,
Opt_err,
......@@ -436,7 +491,7 @@ Index: linux-stage/fs/ext3/super.c
};
static match_table_t tokens = {
@@ -633,6 +634,9 @@
@@ -621,6 +622,9 @@ static match_table_t tokens = {
{Opt_ignore, "noquota"},
{Opt_ignore, "quota"},
{Opt_ignore, "usrquota"},
......@@ -446,7 +501,7 @@ Index: linux-stage/fs/ext3/super.c
{Opt_barrier, "barrier=%u"},
{Opt_err, NULL}
};
@@ -914,6 +918,18 @@
@@ -823,6 +827,18 @@ static int parse_options (char * options
else
clear_opt(sbi->s_mount_opt, BARRIER);
break;
......@@ -465,11 +520,11 @@ Index: linux-stage/fs/ext3/super.c
case Opt_ignore:
break;
default:
Index: linux-stage/include/linux/ext3_fs.h
Index: linux-2.6.5-7.311/include/linux/ext3_fs.h
===================================================================
--- linux-stage.orig/include/linux/ext3_fs.h 2005-02-25 14:37:28.977023064 +0200
+++ linux-stage/include/linux/ext3_fs.h 2005-02-25 14:49:00.569884968 +0200
@@ -355,6 +355,8 @@
--- linux-2.6.5-7.311.orig/include/linux/ext3_fs.h
+++ linux-2.6.5-7.311/include/linux/ext3_fs.h
@@ -329,6 +329,8 @@ struct ext3_inode {
#define EXT3_MOUNT_POSIX_ACL 0x08000 /* POSIX Access Control Lists */
#define EXT3_MOUNT_RESERVATION 0x10000 /* Preallocation */
#define EXT3_MOUNT_BARRIER 0x20000 /* Use block barriers */
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment