Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
L
lustre-release
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
External wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
debian-packages
lustre-release
Commits
1350abfe
Commit
1350abfe
authored
22 years ago
by
gord-fig
Browse files
Options
Downloads
Patches
Plain Diff
Clean up extN patch and dist rules.
parent
3511b879
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
lustre/extN/Makefile.am
+8
-9
8 additions, 9 deletions
lustre/extN/Makefile.am
lustre/scripts/lustre.spec.in
+2
-2
2 additions, 2 deletions
lustre/scripts/lustre.spec.in
with
10 additions
and
11 deletions
lustre/extN/Makefile.am
+
8
−
9
View file @
1350abfe
...
@@ -12,10 +12,12 @@ EXTNP = htree-ext3-2.4.18.diff linux-2.4.18ea-0.8.26.diff
...
@@ -12,10 +12,12 @@ EXTNP = htree-ext3-2.4.18.diff linux-2.4.18ea-0.8.26.diff
EXTNP
+=
ext3-2.4.18-ino_sb_macro.diff extN-misc-fixup.diff
EXTNP
+=
ext3-2.4.18-ino_sb_macro.diff extN-misc-fixup.diff
EXTNC
=
balloc.c bitmap.c dir.c file.c fsync.c ialloc.c inode.c ioctl.c
EXTNC
=
balloc.c bitmap.c dir.c file.c fsync.c ialloc.c inode.c ioctl.c
EXTNC
+=
namei.c super.c symlink.c
EXTNC
+=
namei.c super.c symlink.c
EXTNI
=
extN_fs.h extN_fs_i.h extN_fs_sb.h extN_jbd.h
EXTN_EXTRA
=
../include/linux/xattr.h ../include/linux/extN_xattr.h
\
EXTN_EXTRA
=
include/linux/xattr.h include/linux/extN_xattr.h fs/extN/xattr.c fs/extN/hash.c
../fs/extN/xattr.c ../fs/extN/hash.c ../include/linux/extN_fs.h
\
extN_SOURCES
=
$(
EXTNC
)
$(
EXTNI
)
xattr.c
# punch.c
../include/linux/extN_fs_i.h ../include/linux/extN_fs_sb.h
\
extN_DEPENDENCIES
=
patch-stamp
../include/linux/extN_jbd.h
extN_SOURCES
=
$(
EXTNC
)
xattr.c
# punch.c
extN_DEPENDENCIES
=
patch-stamp
$(
EXTN_EXTRA
)
EXTRA_DIST
=
$(
EXTNP
)
extN-2.4.18-ino_sb_fixup.diff extN-2.4.18-exports.diff
EXTRA_DIST
=
$(
EXTNP
)
extN-2.4.18-ino_sb_fixup.diff extN-2.4.18-exports.diff
DISTCLEANFILES
=
$(
extN_SOURCES
)
patch-stamp
*
.orig
*
.rej
DISTCLEANFILES
=
$(
extN_SOURCES
)
patch-stamp
*
.orig
*
.rej
SUB
=
-e
"s/ext3/extN/g"
-e
"s/EXT3/EXTN/g"
SUB
=
-e
"s/ext3/extN/g"
-e
"s/EXT3/EXTN/g"
...
@@ -38,7 +40,7 @@ patch-stamp: $(EXTNP)
...
@@ -38,7 +40,7 @@ patch-stamp: $(EXTNP)
$(
RM
)
$@
$(
RM
)
$@
test
-e
$(
top_srcdir
)
/fs
||
ln
-sf
.
$(
top_srcdir
)
/fs
test
-e
$(
top_srcdir
)
/fs
||
ln
-sf
.
$(
top_srcdir
)
/fs
set
-vx
;
\
set
-vx
;
\
list
=
'
$(
EXTN_EXTRA
)
'
;
for
f
in
$$
list
;
do
$(
RM
)
$(
top_
srcdir
)
/
$$
f
;
done
list
=
'
$(
EXTN_EXTRA
)
'
;
for
f
in
$$
list
;
do
$(
RM
)
$(
srcdir
)
/
$$
f
;
done
set
-vx
;
\
set
-vx
;
\
list
=
'
$(
EXTNC
)
'
;
for
f
in
$$
list
;
do
\
list
=
'
$(
EXTNC
)
'
;
for
f
in
$$
list
;
do
\
sed
$(
SUB
)
$(
LINUX
)
/fs/ext3/
$$
f
>
$(
top_srcdir
)
/fs/extN/
$$
f
;
\
sed
$(
SUB
)
$(
LINUX
)
/fs/ext3/
$$
f
>
$(
top_srcdir
)
/fs/extN/
$$
f
;
\
...
@@ -68,7 +70,4 @@ $(extN_SOURCES) $(EXTN_EXTRA): patch-stamp
...
@@ -68,7 +70,4 @@ $(extN_SOURCES) $(EXTN_EXTRA): patch-stamp
dist-hook
:
dist-hook
:
$(
RM
)
$(
top_srcdir
)
/fs
$(
RM
)
$(
top_srcdir
)
/fs
list
=
'
$(
EXTNC
)
'
;
for
f
in
$$
list
;
do
$(
RM
)
$(
distdir
)
/
$$
f
;
done
list
=
'
$(
EXTNC
)
'
;
for
f
in
$$
list
;
do
$(
RM
)
$(
distdir
)
/
$$
f
;
done
list
=
'
$(
EXTNI
)
'
;
for
i
in
$$
list
;
do
\
list
=
'
$(
EXTN_EXTRA
)
'
;
for
f
in
$$
list
;
do
$(
RM
)
$(
distdir
)
/
$$
f
;
done
$(
RM
)
$(
distdir
)
/../include/linux/
$$
i
;
\
done
list
=
'
$(
EXTN_EXTRA
)
'
;
for
f
in
$$
list
;
do
$(
RM
)
$(
distdir
)
/../
$$
f
;
done
This diff is collapsed.
Click to expand it.
lustre/scripts/lustre.spec.in
+
2
−
2
View file @
1350abfe
# lustre.spec
# lustre.spec
%define version
0.5.3
%define version
HEAD
%define kversion @RELEASE@
%define kversion @RELEASE@
%define linuxdir @LINUX@
%define linuxdir @LINUX@
%define portalsdir @PORTALS@
%define portalsdir @PORTALS@
Release:
2
Release:
0208101108
Summary: Lustre Lite File System
Summary: Lustre Lite File System
Name: lustre-lite
Name: lustre-lite
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment