Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
L
lustre-release
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
External wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
debian-packages
lustre-release
Commits
63addaf0
Commit
63addaf0
authored
18 years ago
by
Eric Barton
Browse files
Options
Downloads
Patches
Plain Diff
* landing build diffs from b_release_1_4_7_1
parent
d0a54de6
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
build/Makefile.in.toplevel
+0
-1
0 additions, 1 deletion
build/Makefile.in.toplevel
build/autoMakefile.am.toplevel
+2
-3
2 additions, 3 deletions
build/autoMakefile.am.toplevel
build/autoconf/lustre-build.m4
+1
-105
1 addition, 105 deletions
build/autoconf/lustre-build.m4
with
3 additions
and
109 deletions
build/Makefile.in.toplevel
+
0
−
1
View file @
63addaf0
subdir-m
+=
lnet
subdir-m
+=
lnet
subdir-m
+=
lustre
subdir-m
+=
lustre
@BUILD_PORTALS_TRUE@
subdir-m
+=
portals
@INCLUDE_RULES@
@INCLUDE_RULES@
This diff is collapsed.
Click to expand it.
build/autoMakefile.am.toplevel
+
2
−
3
View file @
63addaf0
AUTOMAKE_OPTIONS = foreign
AUTOMAKE_OPTIONS = foreign
SUBDIRS := . build @LIBSYSIO_SUBDIR@ @SNMP_SUBDIR@ lnet
@LUSTRE_PORTALS_SUBDIR@
lustre
SUBDIRS := . build @LIBSYSIO_SUBDIR@ @SNMP_SUBDIR@ lnet lustre
DIST_SUBDIRS := build @SNMP_DIST_SUBDIR@ libsysio lnet
@LUSTRE_PORTALS_SUBDIR@
lustre
DIST_SUBDIRS := build @SNMP_DIST_SUBDIR@ libsysio lnet lustre
EXTRA_DIST := config.h.in
EXTRA_DIST := config.h.in
...
@@ -30,7 +30,6 @@ if MODULES
...
@@ -30,7 +30,6 @@ if MODULES
all-sources:
all-sources:
$(MAKE) sources -C lnet
$(MAKE) sources -C lnet
$(MAKE) sources -C lustre
$(MAKE) sources -C lustre
if [ "x@LUSTRE_PORTALS_SUBDIR@" = "xportals" ] ; then $(MAKE) sources -C @LUSTRE_PORTALS_SUBDIR@ ; fi
if LINUX
if LINUX
all-am: modules
all-am: modules
...
...
This diff is collapsed.
Click to expand it.
build/autoconf/lustre-build.m4
+
1
−
105
View file @
63addaf0
...
@@ -158,92 +158,6 @@ esac
...
@@ -158,92 +158,6 @@ esac
AC_CONFIG_SUBDIRS(libsysio)
AC_CONFIG_SUBDIRS(libsysio)
])
])
#
# LB_CONFIG_PORTALS
#
# configure support for Cray Portals
#
AC_DEFUN([LB_CONFIG_PORTALS],
[AC_MSG_CHECKING([for external Portals])
AC_ARG_WITH([portals],
AC_HELP_STRING([--with-portals=path],
[set path to portals]),
[
case $with_portals in
no) PORTALS=""
enable_portals=no
;;
*) if test x$with_portals != x ; then
PORTALS="$with_portals"
enable_portals=yes
else
AC_MSG_ERROR([Path to portals must be specified])
enable_portals=no
fi
;;
esac
], [enable_portals=no])
AC_MSG_CHECKING([location of portals])
case x$enable_portals in
xyes)
AC_MSG_RESULT([$PORTALS])
LB_CHECK_FILE([$PORTALS/include/portals/api.h],[],
AC_MSG_ERROR([Cannot find portals headers]))
;;
*)
AC_MSG_RESULT([no external portals])
;;
esac
AC_SUBST(PORTALS)
])
#
# LB_CONFIG_LUSTRE_PORTALS
#
# configure support for Lustre Portals
#
AC_DEFUN([LB_CONFIG_LUSTRE_PORTALS],
[AC_MSG_CHECKING([for Lustre Portals])
AC_ARG_WITH([lustre-portals],
AC_HELP_STRING([--with-lustre-portals=path],
[set path to Lustre portals]),
[
case $with_lustre_portals in
yes) LUSTRE_PORTALS="$PWD/portals"
enable_lustre_portals=yes
;;
no) LUSTRE_PORTALS=""
enable_lustre_portals=no
;;
*) if test x$with_lustre_portals != x ; then
LUSTRE_PORTALS="$with_lustre_portals"
else
LUSTRE_PORTALS="$PWD/portals"
fi
enable_lustre_portals=yes
;;
esac
], [enable_lustre_portals=no])
AC_MSG_CHECKING([location of Lustre portals])
case x$enable_lustre_portals in
xyes)
AC_MSG_RESULT([$LUSTRE_PORTALS])
LB_CHECK_FILE([$LUSTRE_PORTALS/include/portals/api.h],[LUSTRE_PORTALS_SUBDIR="portals"],
AC_MSG_ERROR([Cannot find Lustre portals headers]))
;;
*)
AC_MSG_RESULT([disable Lustre portals])
;;
esac
AC_SUBST(LUSTRE_PORTALS_SUBDIR)
AC_SUBST(LUSTRE_PORTALS)
])
#
#
# LB_CONFIG_CRAY_XT3
# LB_CONFIG_CRAY_XT3
#
#
...
@@ -536,7 +450,6 @@ AM_CONDITIONAL(UTILS, test x$enable_utils = xyes)
...
@@ -536,7 +450,6 @@ AM_CONDITIONAL(UTILS, test x$enable_utils = xyes)
AM_CONDITIONAL(TESTS, test x$enable_tests = xyes)
AM_CONDITIONAL(TESTS, test x$enable_tests = xyes)
AM_CONDITIONAL(DOC, test x$ENABLE_DOC = x1)
AM_CONDITIONAL(DOC, test x$ENABLE_DOC = x1)
AM_CONDITIONAL(INIT_SCRIPTS, test x$ENABLE_INIT_SCRIPTS = "x1")
AM_CONDITIONAL(INIT_SCRIPTS, test x$ENABLE_INIT_SCRIPTS = "x1")
AM_CONDITIONAL(BUILD_PORTALS, test x$LUSTRE_PORTALS_SUBDIR = "xportals")
AM_CONDITIONAL(LINUX, test x$lb_target_os = "xlinux")
AM_CONDITIONAL(LINUX, test x$lb_target_os = "xlinux")
AM_CONDITIONAL(DARWIN, test x$lb_target_os = "xdarwin")
AM_CONDITIONAL(DARWIN, test x$lb_target_os = "xdarwin")
...
@@ -556,9 +469,6 @@ LB_DARWIN_CONDITIONALS
...
@@ -556,9 +469,6 @@ LB_DARWIN_CONDITIONALS
LN_CONDITIONALS
LN_CONDITIONALS
LC_CONDITIONALS
LC_CONDITIONALS
#if test "$LUSTRE_PORTALS" ; then
LP_CONDITIONALS
#fi
])
])
#
#
...
@@ -571,11 +481,6 @@ AC_DEFUN([LB_CONFIGURE],
...
@@ -571,11 +481,6 @@ AC_DEFUN([LB_CONFIGURE],
LB_INCLUDE_RULES
LB_INCLUDE_RULES
LB_CONFIG_PORTALS
if ! test "$PORTALS" ; then
# if portals is configured, Lustre portals will be ignored
LB_CONFIG_LUSTRE_PORTALS
fi
LB_CONFIG_CRAY_XT3
LB_CONFIG_CRAY_XT3
LB_CONFIG_BGL
LB_CONFIG_BGL
LB_PATH_DEFAULTS
LB_PATH_DEFAULTS
...
@@ -585,10 +490,6 @@ LB_PROG_CC
...
@@ -585,10 +490,6 @@ LB_PROG_CC
LB_PATH_LIBSYSIO
LB_PATH_LIBSYSIO
LB_PATH_SNMP
LB_PATH_SNMP
if test "$LUSTRE_PORTALS" ; then
LP_PROG_CC
fi
LB_CONFIG_DOCS
LB_CONFIG_DOCS
LB_CONFIG_UTILS
LB_CONFIG_UTILS
LB_CONFIG_TESTS
LB_CONFIG_TESTS
...
@@ -602,9 +503,7 @@ LC_CONFIG_LIBLUSTRE
...
@@ -602,9 +503,7 @@ LC_CONFIG_LIBLUSTRE
LN_CONFIGURE
LN_CONFIGURE
LC_CONFIGURE
LC_CONFIGURE
if test "$LUSTRE_PORTALS" ; then
LP_CONFIGURE
fi
if test "$SNMP_DIST_SUBDIR" ; then
if test "$SNMP_DIST_SUBDIR" ; then
LS_CONFIGURE
LS_CONFIGURE
fi
fi
...
@@ -623,9 +522,6 @@ build/lustre.spec
...
@@ -623,9 +522,6 @@ build/lustre.spec
LN_CONFIG_FILES
LN_CONFIG_FILES
LC_CONFIG_FILES
LC_CONFIG_FILES
if test "$LUSTRE_PORTALS" ; then
LP_CONFIG_FILES
fi
if test "$SNMP_DIST_SUBDIR" ; then
if test "$SNMP_DIST_SUBDIR" ; then
LS_CONFIG_FILES
LS_CONFIG_FILES
fi
fi
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment