Skip to content
Snippets Groups Projects
Commit 9fd45a23 authored by ccooper's avatar ccooper
Browse files

- chaos kernel only needs half of the old inode-max-readahead patch, so added...

- chaos kernel only needs half of the old inode-max-readahead patch, so added a new patch just for chaos-2.4.18
- updated series file for chaos-2.4.18
- updated tinderbox info for chaos-2.4.18
- lbuild: removed '-D' option to cvs which was tanking builds on most clusters, cascading check for rpmbuild and rpm as the method to make rpms
parent 37113b4c
No related branches found
No related tags found
No related merge requests found
--- linux-2.4.24-l32/include/linux/fs.h.inode_ramax 2004-03-14 13:15:49.000000000 -0800
+++ linux-2.4.24-l32/include/linux/fs.h 2004-03-15 11:56:56.000000000 -0800
@@ -410,6 +410,8 @@
#define KERNEL_HAS_DIRECT_FILEIO /* Unfortunate kludge due to lack of foresight */
int (*direct_fileIO)(int, struct file *, struct kiobuf *, unsigned long, int);
void (*removepage)(struct page *); /* called when page gets removed from the inode */
+#define KERNEL_HAS_AS_MAX_READAHEAD
+ int (*max_readahead)(struct inode *);
};
struct address_space {
...@@ -36,5 +36,5 @@ ext3-xattr-ptr-arith-fix.patch ...@@ -36,5 +36,5 @@ ext3-xattr-ptr-arith-fix.patch
kernel_text_address-2.4.18-chaos.patch kernel_text_address-2.4.18-chaos.patch
procfs-ndynamic-2.4.patch procfs-ndynamic-2.4.patch
ext3-truncate-buffer-head.patch ext3-truncate-buffer-head.patch
inode-max-readahead-2.4.24.patch inode-max-readahead-chaos-2.4.18.patch
dcache_refcount_debug.patch dcache_refcount_debug.patch
KERNEL=linux-2.4.18-p4smp-86chaos.tar.gz KERNEL=linux-2.4.18-p4smp-87chaos.tar.gz
SERIES=chaos-2.4.18 SERIES=chaos-2.4.18
VERSION=2.4.18 VERSION=2.4.18
EXTRA_VERSION=p4smp-86chaos EXTRA_VERSION=p4smp-87chaos
RHBUILD=0 RHBUILD=0
BASE_ARCHS="i686" BASE_ARCHS="i686"
......
...@@ -29,6 +29,8 @@ UP_ARCHS= ...@@ -29,6 +29,8 @@ UP_ARCHS=
DATE=$(date) DATE=$(date)
RPMBUILD=
cleanup() cleanup()
{ {
true true
...@@ -147,6 +149,14 @@ check_options() ...@@ -147,6 +149,14 @@ check_options()
# TARGET_FILE="$TOPDIR/kernel_patches/targets/$TARGET.target" # TARGET_FILE="$TOPDIR/kernel_patches/targets/$TARGET.target"
# [ -r "$TARGET_FILE" ] || \ # [ -r "$TARGET_FILE" ] || \
# usage 1 "Target '$TARGET' was not found." # usage 1 "Target '$TARGET' was not found."
RPMBUILD=`which rpmbuild`
if [ $? -ne 0 -o ! "$RPMBUILD" -o "$RPMBUILD" == "" ]; then
RPMBUILD=`which rpm`
if [ $? -ne 0 -o ! "$RPMBUILD" -o "$RPMBUILD" == "" ]; then
usage 1 "Could not find binary for making rpms (tried rpmbuild and rpm)."
fi
fi
} }
uniqify() uniqify()
...@@ -234,7 +244,7 @@ unpack_lustre() ...@@ -234,7 +244,7 @@ unpack_lustre()
untar "$LUSTRE" untar "$LUSTRE"
[ -d lustre ] || ln -sf lustre* lustre [ -d lustre ] || ln -sf lustre* lustre
else else
cvs -d "$CVSROOT" -qz3 co -D "$DATE" "-r$TAG" -d "$DIRNAME" lustre || \ cvs -d "$CVSROOT" -qz3 co -r "$TAG" -d "$DIRNAME" lustre || \
fatal 1 "There was an error checking out Lustre from CVS." fatal 1 "There was an error checking out Lustre from CVS."
echo "Creating lustre tarball..." echo "Creating lustre tarball..."
tar zcf "$DIRNAME.tar.gz" "$DIRNAME" \ tar zcf "$DIRNAME.tar.gz" "$DIRNAME" \
...@@ -338,11 +348,11 @@ build() ...@@ -338,11 +348,11 @@ build()
targets="--target $arch $targets" targets="--target $arch $targets"
done done
rpmbuild $targets -bb lustre-kernel-2.4.spec \ $RPMBUILD $targets -bb lustre-kernel-2.4.spec \
--define "_topdir $TOPDIR" || \ --define "_topdir $TOPDIR" || \
fatal 1 "Error building rpms for $arch." fatal 1 "Error building rpms for $arch."
(( $DO_SRC )) && rpmbuild -bs lustre-kernel-2.4.spec \ (( $DO_SRC )) && $RPMBUILD -bs lustre-kernel-2.4.spec \
--define "_topdir $TOPDIR" || \ --define "_topdir $TOPDIR" || \
fatal 1 "Error building .src.rpm." fatal 1 "Error building .src.rpm."
} }
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment